QML Linux library dependences



  • Hey guy, till now I was developing on a Windows plattform.
    Now I started developing my apps on a linux system.

    I already tried my app on a openSuse distr. with success.
    Now I have a linux mint distri to develop on but I had some
    issues with this system.

    I tried the QML demos but they didn't work either.
    It's hard to explain what the problem is. It looks like the
    QML elements can't be rendered correctly. There is no
    text on the elements, colors aren't rendered correct,
    image elements cant't be displayed as expected and so on.

    Before I'm going to post images which show the problem I
    just wanna ask if there are any libraries that has to be available
    on the system to get qml to work.

    As mentioned, I already get qml to work on my openSuse
    the Linux Mint is pretty fresh and I guess that there could
    be some dependences which aren't installed on the system.

    Hope that anybody has an idea.
    Thanks



  • Maybe you have a newer version of Qt in mint than openSuse? Some things have changed between the release candidates and the final 4.7 release.

    You could also execute 'ldd /usr/bin/qmlviewer' to see if all libs/dependencies are available.



  • Do you have any display trouble with other parts of Qt, or just QML? If you run with a different graphicssystem (e.g. -graphicssystem native or -graphicssystem opengl) are the results the same?



  • @mario

    I don't have the qmlviewer in /usr/bin/ but in /usr/local/Trolltech/..

    I tried some of the examples in the Creator and they work well.
    The same examples didn't work from the qtdemo. I'm a bit confused about this behavior.

    the dependencies seemed to be ok.

    @mbrasser

    It looks like qml is the only part which has the problem.
    Although I noticed some issues with png icons and that kind of stuff, but my libpng woks fine.

    I already tried to run in a different graphics system but this does help either.



  • Hi,

    If they are working fine from Creator, but not from qtdemo, running with "-graphicssystem raster" may help (this is set by default when running qmlviewer/qmlobserver, but not when running qtdemo).

    Regards,
    Michael


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.