Problem building qt mobility 1.1.0 beta2 on os x



  • after running configure (and met all dependencies i believe), i encountered this error during make:

    qlandmarkfilehandler_lmx_p.h:68: error: forward declaration of ‘struct QXmlStreamWriter’
    qlandmarkfilehandler_lmx.cpp:930: error: invalid use of incomplete type ‘struct QXmlStreamWriter’
    qlandmarkfilehandler_lmx_p.h:68: error: forward declaration of ‘struct QXmlStreamWriter’
    lipo: can't open input file: /var/folders/5V/5V4vr7WoH+0SIBETfcWpb++++TI/-Tmp-//ccK7yH1u.out (No such file or directory)
    make[4]: *** [../../../build/Debug/qtlandmarks_sqlite_debug/qlandmarkfilehandler_lmx.o] Error 1
    make[3]: *** [debug-all] Error 2
    make[2]: *** [sub-sqlite-make_default-ordered] Error 2
    make[1]: *** [sub-landmarks-make_default] Error 2
    make: *** [sub-plugins-make_default-ordered] Error 2

    I was wondering if anyone has insight about this.

    Regards,

    Zhao



  • The qlandmarkfilehandler_lmx.cpp file should include QXmlStreamWriter, while it doesn't currently -- it only knows that the type exists, because it was predeclared:

    @struct XmlStreamWriter;@

    You should check whether the include is actually done.



  • Try add to top of qlandmarkfilehandler_lmx.cpp
    @
    #include <QXmlStreamWriter>
    @



  • Hi,
    Does any body have idea ?

    I have build a small Qt application and had run it on Windows – it runs successfully but when I tried to run the similar application with Qt-lighthouse in Linux environment, it gives me following error message!

    Failed to load platform plugin “ ” Available platforms are:
    LinuxFb
    LinuxRfb
    Minimal
    Sylph
    QVFb
    VNC
    The Programme has unexpectedly finished.

    Now the question raises how can I load the suitable plug-ins that can support this programme with Linux ?

    Would it be very grateful if you can help me or guide me in proper direction.

    Br, Tanveer


  • Moderators

    tanveerulm: Please do not try to abduct other people's issues. Thanks!



  • [quote author="Vass" date="1288343753"]Try add to top of qlandmarkfilehandler_lmx.cpp
    @
    #include <QXmlStreamWriter>
    @[/quote]

    This line exists. Thanks.



  • i tried git clone from gitorious for the latest code, same error.
    spoken with Alex Blasche at qt developer conference and he suggested that i open a bug: "http://bugreports.qt.nokia.com/browse/QTMOBILITY-688 ":http://bugreports.qt.nokia.com/browse/QTMOBILITY-688


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.