GDb Process exited unexpectedly ( code 0 ) , During startup program exited with code 0x0



  • Hi Experts,

    I am beginner in C++ and QT. I installed the Qt in my desktop. It was running fine until recently I tried to build a standalone executable file. I was trying to set some configurations and I started getting these errors if I try to debug non-demo applications:

    gdb process exited unexpectedly (code 0)
    During startup program exited with code 0x0

    I figured that this error might be due to some configuration problem in Tools->Options->Debugger.
    Here, If I try to add Qt sources in Source Paths mapping, it adds following:

    Source Path
    C:\iwmake\build_mingw_opensource
    C:\ndk_buildrepos\qt-desktop\src
    C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more\Troll\4.6\qt

    I cant understand where these folders are coming from. i searched for forums, but couldn't get any satisfactory outcome.
    Can anyone please tell what is going wrong and what is this source and target path?

    Thanks in advance....



  • Hello

    Do you compile in debug mode ?
    Projects /compile parameters / Debug

    Frederic



  • Solved it.
    If I go to
    Projects>Run options>execution I have to uncheck ‘Run in Terminal’ and I can debug.



  • Hi.
    I use Windows 7 and QtCreator as an IDE for C++ Only projects (without qt stuff). Everything compiles. But when I click on this play button with the bug on it for starting the Debug a smal messagebox appears to tell me:
    GDb Process exited unexpectedly ( code 0 ) , During startup program exited with code 0x0

    Anyway it compiles and runs my code.

    Using google I discovered the following:
    https://bugreports.qt-project.org/browse/QTCREATORBUG-6141
    Does this have to do something with my problem?

    So what is wrong with this gdc thing and how can I fix it. I really can't help myself here!
    Pleas help if you have any idea.
    love, Boris



  • I solved it.
    If I go to
    Projects>Run options>execution I have to uncheck 'Run in Terminal' and I can debug.



  • @BorisMonth:
    Is this option also on Qt 5.0 b/s I couldn't find it in run options


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.