[SOLVED]Qt Creator Intellisense or autocomplete not working?



  • This is the first time it didn't work. I'm using Qt Creator 2.4.1
    When i use @QList<int>:: @ intellisense stops giving any suggestions. I hit ctrl+Space nothing happens. I have included the QList header.
    But when i manually enter QList<int>::iterator , it recognizes it and the code gets highlighted.
    But in this video it is working :-http://www.youtube.com/watch?v=-xGGPfdQ-n4&t=48s
    But that is a different version of Qt creator.
    So is something wrong with my installation or does the 2.4.1 version has some problem? Does it work for anybody else? can somebody try this for me?



  • not a big deal u can try and maually code that part...
    some times it happens with templated class or when the creator is not able to find the class properly...

    but this will not give u error, u can directly write method which is not shown by the intellisense....



  • Thanks shoyeb,
    Yes i can manually do it but still
    Does it work for others using the version or is it just my installation?
    I wanted to know.Because if there is something wrong with my installation then i can reinstall.



  • even in my machine also it didn't worked so i told u to do it manually.. :)

    if its not working then it doesnot mean that there's something wrong with ur installation..
    its just dat ur Qt creator is not able to find that method or class...

    if there is anything wrong with ur installation then u would not be able to run a single project on it... :)



  • Thanks,
    That answers my question


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.