Error Installing qt 4.8 for embedded linux Please help



  • Hi all,

    I am newbie in the world of linux and QT. I am trying to install QT for my debian system. I am following the steps as documented in the following link.

    http://developer.qt.nokia.com/doc/qt-4.8/qt-embedded-install.html

    But when I use the ./confure Command I am getting the following error message -

    "You don't seem to have make or gmake in your PATH"
    "Cannot Proceed"

    I am not able to install QT

    Please help ..


  • Moderators

    You do need a couple of tools and dependent libraries to build Qt and you seem to be missing those.

    Please install make, g++, perl and a couple of others (I can't remember the complete list at the top of my head). Installing "build-essential" should get you a solid base. If there is anything missing after installing that, just check your software repositories for whatever is missing.

    Note that for any missing library you will need to install the LIBRARY_NAME-dev package to get the headers, etc.



  • Thanks for the reply...I did install make, g++ and the installation started ....thanks ...will let u know once the installation is done.



  • I am getting this following error -

    ../WebCore/accessibility/AXObjectCache.h:184: error: unused parameter 'postToElement'

    any suggestion for this error ??

    Thanks in advance


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.