[SOLVED] QtCreator jumps to front when build complete



  • And it's really annoying when I'm typing in another window while the build's going on.

    I don't recall this happening with QtCreator 2.2. And I can't find any obvious option to disable this behaviour. Are there any un-obvious options?

    Thanks!



  • OS?


  • Moderators

    Which OS are you on? Which creator version are you using and where did you get it from?

    Creator jumps to the front of what? Does it bring its window to the front? If that is the case and you are using Linux: Which window manager do you use?



  • Linux (Linux Mint 12). I'm using Mint's Cinnamon desktop.

    QtCreator 2.4.1 downloaded from nokia.com.

    More specifics on the problem: Say I start a build in QtCreator and then bring, say, Terminal to the front to type some commands. When the build finishes, the QtCreator window immediately comes to the front (on top of any other windows) and grabs keyboard focus. So, I usually end up putting a couple characters of my Terminal command into a C++ file. It's really quite aggravating.

    I'm guessing that other people aren't seeing this, though? So, maybe it is something to do with my desktop. Does QtCreator sound a bell or some other kind of "all done" indicator? Maybe my desktop is set to bring such windows to the front? I will see if I can find a setting somewhere regarding that, or see if other apps do it too.


  • Moderators

    Yes, creator does send a signal to the desktop. I am running Linux with a default ubuntu/gnome3 and that pops up a notification when a build is done but does not bring the window to the front.

    Feel free to "file a bug report":http://bugreports.qt-project.org/ , but the issue will most likely not get a very high priority.



  • Thanks for the hints. I eventually determined that the fault lay with the Cinnamon desktop that is part of Linux Mint; it has questionable code to bring windows to the front when they "demand attention".

    https://github.com/linuxmint/Cinnamon/issues/233

    There was a workaround on that bug report which fixed up QtCreator for me, namely disabling the _onWindowDemandsAttention() function in /usr/share/cinnamon/js/ui/windowAttentionHandler.js .


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.