[SOLVED] Unable to install QT in Nokia n97 mini



  • Since Smart Installer is having a bug and I cannot install QT-based apps from ovi store (the installation cancels in the 5th package), I decide to install Molome manually (more information in this "link":http://molo.me/download/symbian) However, this doesn't work either sadly. I installed QT, QT webkit and QMLViewer and QT mobility, but when I try to open QMLViewer, nothing happens. I mean, the app can't even open. When I ignored the problem and tried installing Molome, the same problem happens: I can't open the app. I even tried a hard reset and retried installing QT but nothing helps. This prevents me from installing not only Molome but also any other QT-based apps.

    I wonder if I did something wrong here. Please help me with this problem, I'm getting confused and frustrated with QT.
    Thanks a lot in advance!



  • [quote author="ichigochan" date="1327836761"]Since Smart Installer is having a bug and I cannot install QT-based apps from ovi store (the installation cancels in the 5th package)[/quote]

    Which is the 5th package that cancels?



  • I don't know, when smart installer installs QT in my phone, it notifies something like, "installing 1 of 7"... The installation fails when it's "installing 5 of 7". Have you ever run smart installer in a s60v5 phone? I think it's kinda difficult to describe the problem.

    -Edited-
    I think that 5th package may be QT mobility. The reason is, after the installation cancelled, I checked the installed apps and I can see that the newly installed apps include only C++ stuff, sqlite3, QT webkit and something else I can't remember well. Plus, in the case where I installed QT manually, I can only install QT and QT webkit in C:, but not QT mobility. It said something like "Unable to install", so I had to ignore it and install mobility in E: (mass storage) and the result turned out as above.



  • [quote author="ichigochan" date="1327853297"]Have you ever run smart installer in a s60v5 phone?[/quote]

    Yes, I have run the successfully smart installer on Nokia 5800 but it was long ago. Try again to install manually sis files for Symbian^1 that are shipped with Qt SDK.



  • Okay so I have to install the whole SDK to my pc to find the sis files? Oh, that may consume pretty much time I guess. But maybe I'll give it a try. Thanks for the replies though, I'll report the result later.



  • Hey I tried as you suggested and it doesn't work either. Those sis files are the same as those I downloaded. I'm really frustrated with this problem.



  • Ok I found out the reason for my problem. The malfunction of QT-based apps is caused due to the use of install server patch I use to install unsigned apps.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.