Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt is not working on a Mac



  • Hi,

    Last night I try to install Qt on my Mac and when I click the installer I noticed that the labels on the buttons for the installation were not showing (install, next etc.), the buttons are showing but no labels. I went and proceeded with the installation clicking the buttons without knowing what the buttons said and assuming that they were the typical buttons found when installing other applications. I got it to install but when I opened the application it is also missing the labels on some buttons and drop-down menus. Also, I’m getting and error every time I close the application ("Qt has unexpectedly quit ...").

    Any idea why the labels are not showing?

    Is there anybody there running Qt on a Mac with Lion without issues?

    I’m on a Mac with OX Lion 10.7.2

    See print screen:
    https://skitch.com/fstigre/g56br/qt-creator

    I used the standard download for Mac OSX. I tried both the online and the offline installer and same thing.
    http://qt.nokia.com/downloads

    Thanks a lot for your help!



  • Qt on the Mac usually runs without problems. There have been some troubles with XCode 4 tool chain, but there are solutions/workarounds available. The applications itself (Creator, Designer, Linguist, etc.) run as expected.



  • Thanks a lot for your reply!

    Where can I find information to find the solution?

    I installed Creator separately and same thing, this is what I see when I try to create a new project.
    Print Screen:
    https://skitch.com/fstigre/ghex9/new

    Thanks



  • Wow! I just tried it on my Windows machine and Qt rocks. I wish I could make it work on my Mac which is my primary machine.



  • On my Mac with Lion server all Qt tools run as expected (okeydokey) ...



  • For the xcode problem: just have a forum search for Xcode 4, you should get some results there. I don't have the links at hand right now. For development, I'm still on a snow leo (10.6.x) box, but the applications I build run on lion without any problems. Maybe something went wrong during installation?



  • I have actual downloaded the installer multiple times and installed it multiple times as well.

    Thanks I will try to find a fix for Xcode, even though I dont know exactly what I'm looking for, hopefully I will find something.

    Thanks a lot for your help!



  • Hm, sorry, I never used the SDK. I'm used to build Qt libs from sources for ages now and use the standalone tools. Hopefully someone else, being more familiar with the SDK, can jump in here.



  • After searching the internet and reading similar problems people are having with different software I started thinking that I might be missing the font type used for certain parts of the program, since some people claim to have fixed them by adding the correct font or the encoding type.

    Ref threads.
    http://forums.macrumors.com/showthread.php?t=775283
    http://www.tomshardware.com/forum/34-69-text-empires-trial-version

    Could this be the issue?

    Is there a possibility that I'm missing some fonts or the encoding need to be changed?

    Any one out there having the same problem.

    Thanks a lot for your help "volker"



  • Hi, that font issue sounds reasonable. It would explain why it's only text that's missing.



  • Any idea what are the default fonts Qt is using or where can I find the font configuration folder?

    Thanks a lot.



  • Sorry, I don't even have a guess here :-/



  • Thanks a lot for your help!

    I checked all of my fonts and all of them are active. I also tried to find a folder that could lead me to the font in Qt but nothing.

    I will try to find the solution and if I find it I will post it here otherwise I will just develop on Windows :(



  • Ok, it least I'm not the only one having this issue, I hope this gets fixed soon.

    https://bugreports.qt-project.org/browse/QTCREATORBUG-6837



  • This definitely looks like a broken install, potentially a broken qt.conf. I am using the same Qt Creator on the same Mac Os X, works fine here.



  • Is there something I could do to try to fix it or this would be on Qt's end and I would need to wait for a fix?

    It funny because I actually went and installed an old version (Qt SDK 1.1.2) thinking that that was going to work but nothing, same problem.

    "I refuse to the idea that I would need to develop on two computers Mac/Windows"

    Thanks a lot for your comments.



  • I am relatively certain anything that breaks Qt at runtime after installing the SDK is local to the current user. What you could try is to create a new Mac User, install the SDK there, and run it. If you get the same results there, we need to look in a different direction.



  • Yeah, make sense, I will try that and see what happens.

    Thanks a lot for your help



  • Thats it, I installed it using a different user and it worked, except for the error when closing the application but I can live with that.

    Any idea what could I do with the bad user account?

    Repair permissions maybe, I will try that...

    Thanks a lot you made my day!!!!



  • I repaired permissions but nothing, it didn't fix the problem. Any idea what could be causing the problem?

    Thanks a lot.



  • What could be the cause fo the application to run differently between user accounts?

    Why would some accounts get different setting when the program was installed?

    Any suggestion would be greatly appreciated.

    Thanks a lot!



  • Any one know what files from Qt could be causing the problem?

    I basically tried to create a new user account but I have too many programs using databases, preferences etc that could be broken if I move to a different account.

    Any help will be appreciated.



  • Found and fixed the problem.

    The problem had to do with some corrupted fonts and as soon as I recover my system and user fonts to the default the application started working fine.

    I basically followed the steps in the following page...

    http://www.jklstudios.com/misc/osxfonts.html

    Go to the bottom of the page to the Reinstalling your fonts: section and follow the instructions there. The instructions in this article are to restore your system and library fonts but if you have fonts in your user Fonts folder move them to a different folder and move them back using Font Book, the reason I used Font Book is because when you drop them into it to installed them, Font Book actually verifies that there are no duplicates in the other Fonts folders which could lead to font collision or corrupted fonts.

    Read the whole article to have a better understanding of how fonts work, that’s a very good article.

    Thanks



  • <random_officespace_quote>Man, that is f**ked up. Oh, sorry, carry on.</random_officespace_quote>



  • Thanks for that link. I've bookmarked it immediately :)


Log in to reply