Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT5.15 make install problem - Could not find feature opengl



  • Hi,
    I am doing an upgrade from 5.9 to 5.15 and adapted my old configuration line to

    ./configure -opensource -confirm-license -reduce-exports -release -make libs -extprefix $OUTPUT_DIR 
    -no-openssl 
    -no-opengl 
    -no-gui 
    -no-qml-debug 
    -no-harfbuzz 
    -no-freetype 
    -nomake tests 
    -nomake examples 
    -qt-zlib 
    -qt-libjpeg 
    -qt-libpng 
    -qt-pcre 
    -skip multimedia 
    -skip 3d 
    -skip qtremoteobjects 
    -skip xmlpatterns 
    -skip x11extras 
    -skip winextras 
    -skip webengine 
    -skip androidextras 
    -skip script 
    -feature-statemachinels
    

    the make finishes just fine, but make install causes the following error

    make[3]: Leaving directory '/root/TOOLCHAIN/qt/qt-everywhere-src-5.15.2/qtdeclarative/tools/qml'
    make[2]: Leaving directory '/root/TOOLCHAIN/qt/qt-everywhere-src-5.15.2/qtdeclarative/tools'
    make[1]: Leaving directory '/root/TOOLCHAIN/qt/qt-everywhere-src-5.15.2/qtdeclarative'
    cd qtquick3d/ && ( test -e Makefile || /root/TOOLCHAIN/qt/qt-everywhere-src-5.15.2/qtbase/bin/qmake -o Makefile /root/TOOLCHAIN/qt/qt-everywhere-src-5.15.2/qtquick3d/qtquick3d.pro ) && make -f Makefile install
    Project ERROR: Could not find feature opengl.
    make: *** [Makefile:319: module-qtquick3d-install_subtargets] Error 3
    

    Can anyone help me with what i am missing here. I defined skip 3d and no-opengl .
    I would even have libgl1-mesa-dev installed but am not using it.

    Thanks in advance for any advice



  • I solved it by adding -skip qtquick3d



  • I solved it by adding -skip qtquick3d


Log in to reply