[SOLVED] Qt application DAMAGES its toolbar/menu ICONS after some time...



  • Hi, I've ran into a weird problem with my application's icons. At first my program runs fine, but after some time of operation some or all application icons get damaged.

    The toolbar icons seem to get damaged for some unknown reason. The icons look as if there is some sort of offset introduced which makes them look skewed or torn apart somehow. I wished I could add an png to this post to illustrate what I am talking about.

    I am on OpenSUSE 11.3 with Qt 4.6.3.

    I am wondering whether this is actually due to a too old Qt or whether it's a graphics card issue...

    In fact the same problem occurs with OpenSUSE's Updater Applet icon in KDE's toolbar!!!


  • Moderators

    Sounds strange indeed, a screenshot would help a lot. Have you tried recompiling the app with newer versions of Qt? Or updating OpenSUSE (11.3 is pretty old now)?



  • Unfortunately I am bound to OpenSUSE 11.3, right now. No chance I could update that.

    No, I haven't tried a newer Qt, since that's the one which comes with it.

    (I have built the same app on MacOSX, however, and there I do not see any such thing.)



  • Ah, well, I wished I could add a screenshot to this forum, but I don't see how (w/o using some public web space which I've never used up to now).



  • Just put your image on sites like imageshack or tinypic and put the URL here?



  • OK, will try to do that on Monday. :-)



  • Here is the OpenSUSE updater applet taskbar icon:

    And here is my program which self-destroys all of its toolbar icons after a while:

    Any clue as to what may cause such level of destruction?

    P.S.: Actually I haven't seen this on a OpenSUSE 11.4 yet... Looks like it's really a Qt issue.


  • Moderators

    Used to happen in old KDE builds (by old I mean like 1 year ago), and affected widgets and menus. Didn't happen to me in a while.



  • The question is how to avoid this issue. :-/

    Looks like the only choice I have is to upgrade my OpenSUSE. :-|

    Which I currently can't do. 8-(



  • Via IRC I got the advice that switching to a newer KDE would be possible when using the repo
    @/repositories/KDE:/Distro:/Stable/openSUSE_11.3@

    I'll see whether I can achieve that.



  • In the meantime the repo has vanished at http://download.opensuse.org/repositories/KDE:/Distro:/Stable/ :-(

    I luckily got it mirrored just before that happened, but somehow I can't find the switcher in YaST ( http://dl.dropbox.com/u/10573557/Switcher Pics/kde47_switch.png ) so that I begin to believe that I won't be able to upgrade my old 11.3 to a newer KDE version. :-((



  • Damage is such an inappropriate term for this typical case of corruption :) Not that this is a literature forum or anything, but still it is always a good thing to improve on your terminology :)


  • Moderators

    Offtopic, but...

    bq. Damage is such an inappropriate term for this typical case of corruption

    Not to make too much of it, but as a native speaker, I think it's a quite appropriate term. In fact, it's the exact term my colleagues and I have traditionally used when we have that kind of graphics corruption in our apps.



  • Well, it looks like I have spotted eventually the culprit for this effect.

    I had to replace the driver for my graphics card (NVS 290) with NVIDIA's proprietary driver due to a problem with the noveau driver. The latter actually caused quite a few system hangs!

    After the driver change the icon-damaging did not appear anymore.

    NOVEAU was responsible for both problems.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.