Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QMediaPlayer playbackRate is ignored - linux debian



  • QMediaPlayer used on Linux Debian (with gstreamer installed, and pulseaudio) is ignoring the setPlaybackRate(2.00) - it plays at 100% speed.

    Any hints how to easily fix this, perhaps install some things in Debian?

    I guess it plays through PulseAudio, because I see my program appear in pulsemixer.

    EDIT: it works for .wav files, but fails for .mp3 files



  • I discovered that it can be made to work, if you wait some time after it plays, and then change position of playback (even back to the same position).

    If you do it too soon (e.g. set position 0 right on start) then it doesn't work.

    Not sure what is the event on which that needs to be done to correctly apply the speed/playbackrate setting, so in worst case one can have a timer that keeps calling setposition back to current position all the time.

    It's kinda hack but it works. Is there a better way?


Log in to reply