Important: Please read the Qt Code of Conduct -

Build dependencies

  • Hey guys, I have a bit of an odd question and I am not exactly sure if I understand what's happening well enough to even ask this question in a way that makes sense but I will try.

    I am attempting to use QtMultimedia 5.0 and if I compile the qmlVideo example using the built in kit (Desktop Qt 5.12.3 GCC 64bit) then works correctly. However, if I use my own kit then, although it does compile correctly, I get an error when actually attempting to play a video with it:

    defaultServiceProvider::requestService(): no service found for - "org.qt-project.qt.mediaplayer

    I am assuming this means that when using my kit (which is using a different qmake file coming from a custom QT installation folder) that the costume installation does not have access to that plugin there. So, where exactly do you specify what libs to built for custom installations?

    Would that be done during the Make process of the platform or would it be specified during the Make process for the build? Perhaps you can specify this kind of information in the Built and Run commands for the kit itself? I did not create this custom installation myself so I really don't have much of an idea of how it all works.

  • Alright well I figured out that this needs to be in the config options. Something like:

    QT_CONFIG_OPTIONS += -gstreamer

    however; running that and installing I get and error:

    ERROR: Feature 'gstreamer' was enabled, but the pre-condition 'features.gstreamer_1_0 || features.gstreamer_0_10' failed.

    so one step forward two steps back I guess..

  • Installing the following libs:

    sudo apt-get install libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev

    allows me to get past that error. I will let you know after the installation if I can successfully run the qmlvideo (use QtMultimedia) example with this custom platform install.

  • Alright, yep, that did it. In summary to use this you will need to have the following lib's installed:


    and you will have to have -gstreamer configured on your platform.

Log in to reply