Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Could not create directory - error



  • I have been successfully backing up my project , until today.
    My backups are just plain file copies and it has been working for months.

    The only odd issue was - when I copy and rename the main project folder ( in Linux) I have to "rebuild" it to actually change to the sub folder.
    BUT the initial line , which I cannot not duplicate , always indicated the FIRST ever build sun-folder.

    Now it said "cannot create " such directory .
    So
    is this a OS problem ?
    I suspect so and have no clue how to proceed to recover from this error.

    Even if it is no QT issue , could somebody help me to fix it?

    I have no issue creating "new project ".

    11:46:10: Running steps for project mdi...
    11:46:10: Could not create directory "/media/qe/TSET_QT_LABEL/QT_PROGRAMS/JUNE  6 WORKCOPY 1/CAT/build-mdi-Desktop_Qt_6_2_0_GCC_64bit-Debug"
    Error while building/deploying project mdi (kit: Replacement for "Desktop Qt 6.2.0 GCC 64bit")
    When executing step "qmake"
    11:46:10: Elapsed time: 00:00.
    
    


  • @AnneRanch

    I suggest you to look for the path for your project .pro file to find/resolve the spaces issue. In the Qt Creator, you can switch to Projects tab. There you can look for the Build directory, Build Steps. Under build steps section, there will be for example: qmake: qmake.exe YourProject.pro, click on Details button and you will get Effective qmake call:. There check out your project .pro file path for spaces.

    Also, you can try out to uncheck the Shadow build checkbox and rebuild your project. This option will allow you to build your project in the same directory as your source files. I have attached the screenshots to illustrate it. Make sure there no spaces to your project .pro file. Your issue occurs with qmake step under Build Steps. When qmake executes, it can not find the path to your project .pro file. Also, remove/replace the spaces in your filesystem project directory, otherwise it will not work.

    Screenshots:
    1.jpg

    2.jpg



  • Hello!

    I think, this error could be related to the spaces in your directory path:
    "/media/qe/TSET_QT_LABEL/QT_PROGRAMS/JUNE 6 WORKCOPY 1/CAT/build-mdi-Desktop_Qt_6_2_0_GCC_64bit-Debug"

    Try to replace the spaces to _ underscores for example: "/media/qe/TSET_QT_LABEL/QT_PROGRAMS/JUNE_6_WORKCOPY_1/CAT/build-mdi-Desktop_Qt_6_2_0_GCC_64bit-Debug" and check out if this issue still exists.



  • @Cobra91151 OK, but it worked just fine until today ? I have not knowingly changed anything. I have several similar directories and they all produce same error.
    I can change my current subfolder, but I do not know from where does the line referring to the original , first folder , comes from.
    It does not seems to be in current qmake.
    That never caused major issue, but if it does I need to find where it comes from.
    Any idea ?

    PS
    I can verify your idea by deliberately build a sub folder with spaces. Stand by.

    OK , I cannot create a folder with spaces.
    Now I really need to find where does the "spaced" folder come from and why it became a problem today .
    Appreciate your help.

    I need to identify where and which file this came from

    13:43:19: Could not create directory "/media/qe/TSET_QT_LABEL/QT_PROGRAMS/JUNE 6 WORKCOPY 1/CAT/build-mdi-Desktop_Qt_6_2_0_GCC_64bit-Debug"
    Error while building/deploying project mdi (kit: Replacement for "Desktop Qt 6.2.0 GCC 64bit")
    When executing step "qmake"

    Definitely a problem "When executing step "qmake"



  • @AnneRanch

    I suggest you to look for the path for your project .pro file to find/resolve the spaces issue. In the Qt Creator, you can switch to Projects tab. There you can look for the Build directory, Build Steps. Under build steps section, there will be for example: qmake: qmake.exe YourProject.pro, click on Details button and you will get Effective qmake call:. There check out your project .pro file path for spaces.

    Also, you can try out to uncheck the Shadow build checkbox and rebuild your project. This option will allow you to build your project in the same directory as your source files. I have attached the screenshots to illustrate it. Make sure there no spaces to your project .pro file. Your issue occurs with qmake step under Build Steps. When qmake executes, it can not find the path to your project .pro file. Also, remove/replace the spaces in your filesystem project directory, otherwise it will not work.

    Screenshots:
    1.jpg

    2.jpg



  • SOLVED
    So all this time I have been building using wrong folder!
    The folder indeed had spaces in the name.

    The unanswered question remains - why did it worked until today ?

    Many thanks for helping me to resolve this . Appreciate that very much.


Log in to reply