Qt Creator Debug doesn't work on Windows



  • I'm having this problem for some time, and already tried everything that I found but with no results.

    Everytime I try to debug any application, It runs, but I receive a SIGSEGV (Segmentation Fault) as soon I put the mouse cursor on the application window.

    Already disabled all firewalls and antivirus and rebooted the PC, but is no use. Also tried in three different computers (my desktop, with Windows 7 32bits, my notebook and my work's PC, both with Windows XP SP3), and the problem is identical

    I'm using Qt Creator 2.4 with QtSDK 4.8

    I'm sending the link to debug log in pastebin.

    Can anyone help?

    Thanks in advance

    "Debug log":http://pastebin.com/hbmgCtp0


  • Moderators

    So the segfault happens when you move the mouse pointer over your window?

    Just fix your application.



  • The segfault doesn't happens when I run the same application without the debbuger.

    Also, This happens with ALL applications I try to debug, even if its only an empty QWidget.



  • Debugging with Qt Creator 2.4.0 on Windows works very well here in different environments (mingw32, msvc2008, msvc2010).

    @Tobias
    The debugging in version 2.4.0 is much better/faster than before, thank ;-)


  • Moderators

    Scylla: Not my doing, please direct your thanks to hjk;-)


  • Moderators

    So did you check the backtrace you got?



  • So many thanks to hjk ;-)



  • [quote author="Tobias Hunger" date="1326198528"]So did you check the backtrace you got?[/quote]

    Yeah, but couldn't figure anything, however.

    As I said, the app runs fine until i move de cursor to any point of it's window. When I do, I get the following log:

    "http://pastebin.com/Cx7thnyh":http://pastebin.com/Cx7thnyh

    Checked the libraries loaded, but, except for gbiehAbn.dll (GB Plugin), didn't find anything that could give me a lead. I don't think that the GB Plugin is the problem because I have the same problem on my notebook, and I don't have the GBPlugin installed there.

    and the backtrace shows:
    ~"#0 0x0b3af740 in ?? ()\n"

    ~"#1 0x0b343f5b in ?? ()\n"
    ~"#2 0x0b342f2b in ?? ()\n"
    ~"#3 0x0b340015 in ?? ()\n"
    ~"#4 0x0b3401d3 in ?? ()\n"
    ~"#5 0x0b3401f0 in ?? ()\n"
    ~"#6 0x7c80b699 in KERNEL32!GetModuleFileNameA () from C:\WINDOWS\system32\kernel32.dll\n"
    ~"#7 0x00000000 in ?? ()\n"

    I didn't get much info on it.

    Im not very good on low-level debbuging, then I'm probably overlooking something here.



  • Does anyone have any clue of what could be happening? This problem slows my work a lot =/



  • i have same problem, i try in 3 pc diferents, windows 7, windows vista(core 2 duo) and another widnows vista amdx64...

    Any help?



  • I have this same problem.
    Could anyone else help?


  • Moderators

    Sorry, I have little windows background and can not help:-(

    I would try updating Qt, Qt Creator, the debugger and the compiler, but I have no idea whether that will help or not.



  • Thanks Tobias!

    I´ve already tryed this and doesn´t work.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.