Qt 4.7.0 error on make (invalid pointer to bit-field)



  • I'm trying to compile and install Qt 4.7.0 on AIX 5.3 with gcc 4.2.0 (tried gcc 3.3.2 as well). The make fails on line 181 of qstatemachine.cpp and I'm a little out of my depth:

    @
    179 QStateMachinePrivate::QStateMachinePrivate()
    180 {
    181 QAbstractStatePrivate::isMachine = true;
    182
    @

    The make error:

    @g++ -c -mpowerpc -fpermissive -mminimal-toc -O2 -Wall -W -D_THREAD_SAFE -DQT_SHARED -DQT_BUILD_CORE_LIB -DQT_NO_USING_NAMESPACE -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_USE_FAST_OPERATOR_PLUS -DQT_USE_FAST_CONCATENATION -DHB_EXPORT=Q_CORE_EXPORT -DQT_NO_DEBUG -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../mkspecs/aix-g++ -I. -I../../include -I../../include/QtCore -I.rcc/release-shared -Iglobal -I../3rdparty/harfbuzz/src -I../3rdparty/md5 -I../3rdparty/md4 -I.moc/release-shared -o .obj/release-shared/qstatemachine.o statemachine/qstatemachine.cpp
    statemachine/qstatemachine.cpp: In constructor QStateMachinePrivate::QStateMachinePrivate()': statemachine/qstatemachine.cpp:181: error: invalid pointer to bit-field
    QAbstractStatePrivate::isMachine'
    make[1]: *** [.obj/release-shared/qstatemachine.o] Error 1
    make[1]: Leaving directory `/cc/src/qt-everywhere-opensource-src-4.7.0/src/corelib'
    make: *** [sub-corelib-make_default-ordered] Error 2
    @

    If you need additional information, let me know. I've searched and only found references to this same error, so I'd appreciate places to look as well as things to try. Thanks for any and all help.



  • Are you following the build "tips":http://doc.qt.nokia.com/4.7/compiler-notes.html#ibm-xlc-aix for AIX?

    If yes, file a bug on Qt's bug tracker.



  • Thanks for the reply. I'll file a bug report on it.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.