Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

qtmqtt from git failure within make



  • Hello,
    i am using qt5.11 on a raspberry pi 4 installed from the packages available in raspbian os.
    I can natively run qtcreator and compile the installed modules without problems.

    As there is no qtmqtt module within the packages I tried to install it from git by:

    git clone git://code.qt.io/qt/qtmqtt.git

    Then i ran qmake.
    When running make I got the following error:

    In file included from qmqttclient.cpp:31:
    qmpttclient_p.h:49:10: fatal error: private/qobject_p.h: No such file or directory
    #include <private/qobject_p.h>
    compilation terminated.

    Are qt5.11 and the qtmqtt library/module from this git repository incompatible?
    What are the steps needed to install qtmqtt library/module ?

    To use the CAN bus i would like to use the QSerialBus module, which is also not contained in the
    packages.

    What are the required steps to make it available?

    Thanks in advance for your help.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    If you try to build that module with your distribution provided Qt, you need to install the additional packages that provide Qt's private headers.

    You should also take into account that when you clone one of the modules, you get the dev branch by default which targets Qt 6.


Log in to reply