[Solved] The latest 32-bit QtSDK on Fedora 14, why there is no Desktop build target?



  • Hi, I installed the latest 32-bit SDK for Linux on a Fedora 14 box. I did not find "Desktop build target" when try to compile a program. Could anyone tell me why?

    Thanks.



  • What's "latest SDK" ? I'm using:
    Qt Creator 2.4.0
    Based on Qt 4.7.4 (32 bit)
    Built on Dec 12 2011 at 14:08:19
    From revision b0b0842b03

    and there is Desktop + Simulator + My N9 device ... no problems.
    Fedora 14 32bit.



  • I don't remember the "Build date" and "reversion". I am sure the Creator is 2.4 based on Qt 4.7.4. The host is Fedora 14 32-bit. I only got Simulator and Harmattan build targets. I am trying installation on a 64-bit Fedora to see what I will get. Thanks.



  • In QtCreator goto "About" , there's version and build date.
    When you create new project then it asks about build targets.
    I don't know (didn't try) , how to add more targets in created project if you didn't selected eg. Desktop at the project creation.



  • Hi zeljko, Happy New Year!

    Finally I collected the information:

    Qt Creator 2.4.0
    Based on Qt 4.7.4 (32 bit)
    Built on Dec 20 2011 at 11:14:41
    From revision b0b0842b03

    So basically we have the same build.

    I looked into the package manager in maintenanceTool. I noticed that under the desktop Qt, 4.7.4-1 is installed with 0 byte in size. The Qt Designer and Qt Assistant are NOT installed. I think those two components should be installed. Could you check your installed packages to see if I missed any components?

    Thanks.



  • Yes, you are missing something if QtDesigner is not there.
    I've downloaded online installer and installed all ... that's all I remember.



  • oh..sorry, meant QtCreator :)



  • I think I found the problem. In tools->Options, Qt Build & Run, Qt Versions, the Desktop/.../qmake under Auto-detected was marked as no execution permission. I looked at the Desktop directory. Its permission was 700 in my box, while other directories' were 755. I manually changed Desktop and its subdirectories's permission to 755, which made the Desktop target detected and available.

    I am not sure if this is a bug with the Qt Creator 2.4 build, since I did not see other thread on this issue.



  • I just had the same problem, installing the latest SDK on a 64-bit Ubuntu 11.10 machine as administrator (using sudo). I reinstalled it as myself, which got rid of the problem. But it does seem like a bug in the installer. I will report it as a bug.



  • Actually, this was already reported as "QTSDK-1123":https://bugreports.qt.nokia.com/browse/QTSDK-1123, and has been fixed for the next SDK update.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.