Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt 6 is Frustrating



  • I loaded qt6, finally on Mint Linux, but now I cannot use it. (1) Trying to run a example program, but there are no kits available and the documentation leads me to nowhere. Where can I find out how to load kits? (2) I also installed TexMaker but it seem that Qt is getting the F1 key and not TexMaker. Any thoughts or pointers?


  • Lifetime Qt Champion

    Hi,

    Not knowing how you installed it and what version of Qt Creator your have I do not know why it's not automatically loaded.

    As for adding kit, here is the related documentation from Qt Creator.



  • QT6 was installed using the online open source installer and the Qt Creator opened because the box was checked at the finish of the installation.

    {noformat}
    Qt 5.15.2 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 5.3.1 20160406 (Red Hat 5.3.1-6)) on "xcb"
    OS: Linux Mint 20.1 [linux version 5.4.0-58-generic]

    Architecture: x86_64; features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX AVX2 RTM HLE

    Environment:
    QT_ACCESSIBILITY="1"
    QT_QPA_PLATFORMTHEME="qt5ct"

    Features: QT_NO_EXCEPTIONS

    Library info:
    PrefixPath: /home/bob/Qt/Tools/QtCreator/lib/Qt
    DocumentationPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/doc
    HeadersPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/include
    LibrariesPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/lib
    LibraryExecutablesPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/libexec
    BinariesPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/bin
    PluginsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/plugins
    ImportsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/imports
    Qml2ImportsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/qml
    ArchDataPath: /home/bob/Qt/Tools/QtCreator/lib/Qt
    DataPath: /home/bob/Qt/Tools/QtCreator/lib/Qt
    TranslationsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/translations
    ExamplesPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/examples
    TestsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt/tests
    SettingsPath: /home/bob/Qt/Tools/QtCreator/lib/Qt

    Standard paths [... denote writable entry]:
    DesktopLocation: "Desktop" /home/bob/Desktop
    DocumentsLocation: "Documents" /home/bob/Documents
    FontsLocation: "Fonts" /home/bob/.local/share/fonts /home/bob/.fonts /usr/share/cinnamon/fonts /usr/share/gnome/fonts /home/bob/.local/share/flatpak/exports/share/fonts /var/lib/flatpak/exports/share/fonts /usr/local/share/fonts /usr/share/fonts
    ApplicationsLocation: "Applications" /home/bob/.local/share/applications /usr/share/cinnamon/applications /usr/share/gnome/applications /home/bob/.local/share/flatpak/exports/share/applications /var/lib/flatpak/exports/share/applications /usr/local/share/applications /usr/share/applications
    MusicLocation: "Music" /home/bob/Music
    MoviesLocation: "Movies" /home/bob/Videos
    PicturesLocation: "Pictures" /home/bob/Pictures
    TempLocation: "Temporary Directory" /tmp
    HomeLocation: "Home" /home/bob
    AppLocalDataLocation: "Application Data" /home/bob/.local/share/QtProject/qtdiag /usr/share/cinnamon/QtProject/qtdiag /usr/share/gnome/QtProject/qtdiag /home/bob/.local/share/flatpak/exports/share/QtProject/qtdiag /var/lib/flatpak/exports/share/QtProject/qtdiag /usr/local/share/QtProject/qtdiag /usr/share/QtProject/qtdiag
    CacheLocation: "Cache" /home/bob/.cache/QtProject/qtdiag
    GenericDataLocation: "Shared Data" /home/bob/.local/share /usr/share/cinnamon /usr/share/gnome /home/bob/.local/share/flatpak/exports/share /var/lib/flatpak/exports/share /usr/local/share /usr/share
    RuntimeLocation: "Runtime" /run/user/1000
    ConfigLocation: "Configuration" /home/bob/.config /etc/xdg/xdg-cinnamon /etc/xdg
    DownloadLocation: "Download" /home/bob/Downloads
    GenericCacheLocation: "Shared Cache" /home/bob/.cache
    GenericConfigLocation: "Shared Configuration" /home/bob/.config /etc/xdg/xdg-cinnamon /etc/xdg
    AppDataLocation: "Application Data" /home/bob/.local/share/QtProject/qtdiag /usr/share/cinnamon/QtProject/qtdiag /usr/share/gnome/QtProject/qtdiag /home/bob/.local/share/flatpak/exports/share/QtProject/qtdiag /var/lib/flatpak/exports/share/QtProject/qtdiag /usr/local/share/QtProject/qtdiag /usr/share/QtProject/qtdiag
    AppConfigLocation: "Application Configuration" /home/bob/.config/QtProject/qtdiag /etc/xdg/xdg-cinnamon/QtProject/qtdiag /etc/xdg/QtProject/qtdiag

    File selectors (increasing order of precedence):
    en_US unix linux linuxmint

    Network:
    Using "OpenSSL 1.1.1f 31 Mar 2020", version: 0x1010106f

    Platform capabilities: ThreadedPixmaps OpenGL ThreadedOpenGL WindowMasks MultipleWindows ForeignWindows NonFullScreenWindows NativeWidgets WindowManagement SyncState RasterGLSurface SwitchableWidgetComposition

    Style hints:
    mouseDoubleClickInterval: 400
    mousePressAndHoldInterval: 500
    startDragDistance: 8
    startDragTime: 500
    startDragVelocity: 0
    keyboardInputInterval: 400
    keyboardAutoRepeatRate: 30
    cursorFlashTime: 1200
    showIsFullScreen: 0
    showIsMaximized: 0
    passwordMaskDelay: 0
    passwordMaskCharacter: U+2022
    fontSmoothingGamma: 1.7
    useRtlExtensions: 0
    setFocusOnTouchRelease: 0
    tabFocusBehavior: Qt::TabFocusAllControls
    singleClickActivation: 0

    Additional style hints (QPlatformIntegration):
    ReplayMousePressOutsidePopup: 0

    Theme:
    Platforms requested : gtk3,gnome,generic
    available : gtk3,snap,flatpak,xdgdesktopportal
    Styles requested : fusion,windows
    available : Windows,Fusion
    Icon theme : Mint-Y, from /home/bob/.local/share/icons,/usr/share/cinnamon/icons,/var/lib/flatpak/exports/share/icons,/usr/share/icons
    System font : "Ubuntu" 10
    Native file dialog
    Native color dialog
    Native font dialog

    Fonts:
    General font : "Ubuntu" 10
    Fixed font : "monospace" 10
    Title font : "DejaVu Sans" 12
    Smallest font: "DejaVu Sans" 12

    Palette:
    QPalette::WindowText: #ff000000
    QPalette::Button: #ffefefef
    QPalette::Light: #ffffffff
    QPalette::Midlight: #ffcacaca
    QPalette::Dark: #ff9f9f9f
    QPalette::Mid: #ffb8b8b8
    QPalette::Text: #ff000000
    QPalette::BrightText: #ffffffff
    QPalette::ButtonText: #ff000000
    QPalette::Base: #ffffffff
    QPalette::Window: #ffefefef
    QPalette::Shadow: #ff767676
    QPalette::Highlight: #ff308cc6
    QPalette::HighlightedText: #ffffffff
    QPalette::Link: #ff0000ff
    QPalette::LinkVisited: #ffff00ff
    QPalette::AlternateBase: #fff7f7f7
    QPalette::NoRole: #ff000000
    QPalette::ToolTipBase: #ffffffdc
    QPalette::ToolTipText: #ff000000
    QPalette::PlaceholderText: #80000000

    Screens: 1, High DPI scaling: inactive

    0 "DP-2" Depth: 24 Primary: yes

    Manufacturer: Samsung Electric Company
    Model: SMS27A550H-
    Serial number: 1513304132
    Geometry: 1920x1080+0+0 Available: 1920x1040+0+0
    Physical size: 598x336 mm Refresh: 60 Hz Power state: 0
    Physical DPI: 81.5518,81.6429 Logical DPI: 96,96 Subpixel_None
    DevicePixelRatio: 1 Pixel density: 1
    Primary orientation: 2 Orientation: 2 Native orientation: 0 OrientationUpdateMask: 0

    LibGL Vendor: Intel
    Renderer: Mesa Intel(R) HD Graphics 530 (SKL GT2)
    Version: 4.6 (Compatibility Profile) Mesa 20.0.8
    Shading language: 4.60
    Format: Version: 4.6 Profile: 2 Swap behavior: 0 Buffer size (RGB): 8,8,8
    Profile: None (QOpenGLFunctions_4_6)

    Unable to create a Vulkan instance, error code is0

    Qt Rendering Hardware Interface supported backends:
    OpenGL (with default QSurfaceFormat):
    Min Texture Size: 1
    Max Texture Size: 16384
    Max Color Attachments: 8
    Frames in Flight: 1
    Uniform Buffer Alignment: 1
    Supported MSAA sample counts: 1,2,4,8,16
    Features:
    - MultisampleTexture
    v MultisampleRenderBuffer
    - DebugMarkers
    - Timestamps
    v Instancing
    - CustomInstanceStepRate
    v PrimitiveRestart
    v NonDynamicUniformBuffers
    v NonFourAlignedEffectiveIndexBufferOffset
    v NPOTTextureRepeat
    - RedOrAlpha8IsRed
    v ElementIndexUint
    v Compute
    v WideLines
    v VertexShaderPointSize
    v BaseVertex
    - BaseInstance
    v TriangleFanTopology
    v ReadBackNonUniformBuffer
    v ReadBackNonBaseMipLevel
    Texture formats: RGBA8 BGRA8 R8 R16 RED_OR_ALPHA8 RGBA16F RGBA32F R16F R32F D16 D32F BC1 BC2 BC3 ETC2_RGB8 ETC2_RGB8A1 ETC2_RGBA8

    Failed to load vulkan: Cannot load library vulkan: (vulkan: cannot open shared object file: No such file or directory)
    initInstance: No Vulkan library available
    Failed to create platform Vulkan instance
    Failed to load vulkan: Cannot load library vulkan: (vulkan: cannot open shared object file: No such file or directory)
    initInstance: No Vulkan library available
    Failed to create platform Vulkan instance
    Vulkan instance is not valid

    Plugin information:

    • Android 4.14.1
    • AutoTest 4.14.1
      AutotoolsProjectManager 4.14.1
      BareMetal 4.14.1
    • Bazaar 4.14.1
      Beautifier 4.14.1
    • BinEditor 4.14.1
    • Bookmarks 4.14.1
      Boot2Qt 4.14.1
    • CMakeProjectManager 4.14.1
    • CVS 4.14.1
    • ClangCodeModel 4.14.1
      ClangFormat 4.14.1
    • ClangTools 4.14.1
    • ClassView 4.14.1
      ClearCase 4.14.1
    • CodePaster 4.14.1
      CompilationDatabaseProjectManager 4.14.1
      Conan 4.14.1
    • Core 4.14.1
    • CppEditor 4.14.1
    • CppTools 4.14.1
      Cppcheck 4.14.1
    • CtfVisualizer 4.14.1
    • Debugger 4.14.1
    • Designer 4.14.1
    • DiffEditor 4.14.1
      EmacsKeys 4.14.1
    • FakeVim 4.14.1
    • GLSLEditor 4.14.1
    • GenericProjectManager 4.14.1
    • Git 4.14.1
      HelloWorld 4.14.1
    • Help 4.14.1
    • ImageViewer 4.14.1
    • IncrediBuild 4.14.1
      Ios 4.14.1
    • LanguageClient 4.14.1
    • Macros 4.14.1
    • Marketplace 4.14.1
      McuSupport 4.14.1
    • Mercurial 4.14.1
      MesonProjectManager 4.14.1
    • ModelEditor 4.14.1
      Nim 4.14.1
    • PerfProfiler 4.14.1
      Perforce 4.14.1
    • ProjectExplorer 4.14.1
    • Python 4.14.1
    • QbsProjectManager 4.14.1
    • QmakeProjectManager 4.14.1
    • QmlDesigner 4.14.1
    • QmlJSEditor 4.14.1
    • QmlJSTools 4.14.1
    • QmlPreview 4.14.1
    • QmlProfiler 4.14.1
    • QmlProjectManager 4.14.1
    • Qnx 4.14.1
    • QtSupport 4.14.1
    • RemoteLinux 4.14.1
    • ResourceEditor 4.14.1
    • ScxmlEditor 4.14.1
      SerialTerminal 4.14.1
      SilverSearcher 4.14.1
      StudioWelcome 4.14.1
    • Subversion 4.14.1
    • TaskList 4.14.1
    • TextEditor 4.14.1
      Todo 4.14.1
    • UpdateInfo 4.14.1
    • UsageStatistic 4.14.1
    • Valgrind 4.14.1
    • VcsBase 4.14.1
      WebAssembly 4.14.1
    • Welcome 4.14.1
      WinRt 4.14.1

    Qt Creator 4.14.1
    Based on Qt 5.15.2 (GCC 7.3.1 20180303 (Red Hat 7.3.1-5), 64 bit)
    From revision d8a35381cf
    Built on Feb 23 2021 08:44:05

    {noformat}
    System: Kernel: 5.4.0-58-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 Desktop: Cinnamon 4.8.5
    wm: muffin dm: LightDM Distro: Linux Mint 20.1 Ulyssa base: Ubuntu 20.04 focal
    Machine: Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter>
    Mobo: Gigabyte model: Z170X-Gaming 7 v: x.x serial: <filter> UEFI: American Megatrends
    v: F7 date: 03/11/2016
    CPU: Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP arch: Skylake-S
    rev: 3 L2 cache: 8192 KiB
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 63999
    Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
    5: 801 6: 800 7: 800 8: 800
    Graphics: Device-1: Intel HD Graphics 530 vendor: Gigabyte driver: i915 v: kernel bus ID: 00:02.0
    chip ID: 8086:1912
    Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa
    resolution: 1920x1080~60Hz
    OpenGL: renderer: Mesa Intel HD Graphics 530 (SKL GT2) v: 4.6 Mesa 20.0.8
    direct render: Yes
    Audio: Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a170
    Sound Server: ALSA v: k5.4.0-58-generic
    Network: Device-1: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: 3.2.6-k port: f040
    bus ID: 00:1f.6 chip ID: 8086:15b8
    IF: enp0s31f6 state: down mac: <filter>
    Device-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet vendor: Gigabyte driver: alx
    v: kernel port: d000 bus ID: 04:00.0 chip ID: 1969:e0a1
    IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
    Drives: Local Storage: total: 4.09 TiB used: 11.13 GiB (0.3%)
    ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
    speed: 6.0 Gb/s serial: <filter>
    ID-2: /dev/sdb vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB speed: 6.0 Gb/s
    serial: <filter>
    Partition: ID-1: / size: 441.33 GiB used: 11.13 GiB (2.5%) fs: ext4 dev: /dev/sda6
    Sensors: System Temperatures: cpu: 44.0 C mobo: 29.8 C
    Fan Speeds (RPM): N/A
    Repos: No active apt repos in: /etc/apt/sources.list
    Active apt repos in: /etc/apt/sources.list.d/google-chrome.list
    1: deb [arch=amd64] http: //dl.google.com/linux/chrome/deb/ stable main
    Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
    1: deb http: //packages.linuxmint.com ulyssa main upstream import backport #id:linuxmint_main
    2: deb http: //archive.ubuntu.com/ubuntu focal main restricted universe multiverse
    3: deb http: //archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
    4: deb http: //archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
    5: deb http: //security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
    6: deb http: //archive.canonical.com/ubuntu/ focal partner
    Info: Processes: 307 Uptime: 6h 00m Memory: 15.51 GiB used: 3.29 GiB (21.2%) Init: systemd
    v: 245 runlevel: 5 Compilers: gcc: 9.3.0 alt: 9 Client: Unknown python3.8 client
    inxi: 3.0.38


  • Moderators

    @ofmrew said in Qt 6 is Frustrating:

    there are no kits available

    Basically, a "kit" = "Qt version" + "compatible compiler"

    Do you have g++ installed? Qt is a C++ library, so it needs a C++ compiler.

    PrefixPath: /home/bob/Qt/Tools/QtCreator/lib/Qt

    This points to libraries used by the Qt Creator application. This is different from development libraries that you need to build applications.

    Which version of Qt did you install? See screenshots below for possible choices:



  • @JKSH Qt 6.0.1. Should I have loaded Desktop gcc 64-bit also.


  • Moderators

    @ofmrew said in Qt 6 is Frustrating:

    Qt 6.0.1. Should I have loaded Desktop gcc 64-bit also.

    To get a complete kit, you need to have installed:

    • Qt > Qt 6.0.1 > Desktop gcc 64-bit (from the Qt installer)
    • g++ (from your Linux distro's repo)

    You can launch the MaintenanceTool from your Qt folder to modify your Qt installation.



  • @JKSH I did what you asked and on compiling a program known to work:
    12:20:10: Running steps for project ArcAngles...
    12:20:10: Configuration unchanged, skipping qmake step.
    12:20:10: Starting: "/usr/bin/make" -j8
    g++ -Wl,-rpath,/home/bob/Qt/6.0.1/gcc_64/lib -o ArcAngles main.o mainwindow.o mycanvas.o moc_mainwindow.o moc_mycanvas.o /home/bob/Qt/6.0.1/gcc_64/lib/libQt6Widgets.so /home/bob/Qt/6.0.1/gcc_64/lib/libQt6Gui.so /home/bob/Qt/6.0.1/gcc_64/lib/libQt6Core.so -lpthread -lGL
    /usr/bin/ld: cannot find -lGL
    collect2: error: ld returned 1 exit status
    make: *** [Makefile:184: ArcAngles] Error 1
    12:20:10: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project ArcAngles (kit: Desktop Qt 6.0.1 GCC 64bit)
    When executing step "Make"
    12:20:10: Elapsed time: 00:00.

    It looks like something is wrong with the kit. Any ideas, I hope so because it looks like we are getting close.


  • Lifetime Qt Champion

    No, your kit is fine, you are missing the OpenGL development libraries from your distribution. Just install the corresponding dev package and you'll be good to go.



  • @ofmrew It worked! I found and executed this:
    Enter sudo apt-get update
    Enter sudo apt-get install freeglut3
    Enter sudo apt-get install freeglut3-dev
    Enter sudo apt-get install binutils-gold
    Enter sudo apt-get install g++ cmake
    Enter sudo apt-get install libglew-dev
    Enter sudo apt-get install mesa-common-dev
    Enter sudo apt-get install build-essential
    Enter sudo apt-get install libglew1.5-dev libglm-dev

    I want thank for for your help and tolerating my questions. Next I will try to install qt3d using Conan. So I most likely have questions. Again thanks.


  • Lifetime Qt Champion

    Great !

    Since you have this part working, please mark the thread as solved so that other forum users may know a solution has been found :-)


Log in to reply