Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Trying to get this program to work that uses `python3-qtpy` in Mobian (Debian Mobile)...



  • So when I execute the script, after installing all the dependencies I get this:

    $ sudo python3 execute.py
    qt.qpa.xcb: could not connect to display 
    qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
    
    Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
    
    Aborted
    

    I'll be honest, I don't know offhand what any of that is it's referencing, and that is why I'm here. I'm hoping someone can kinda point me in the direction of the answer. In the meantime I'm just going to be Googling everything it mentions and trying to figure it out myself. I'm just really hoping someone here can save me some time and shepherd me a little to arriving at the answer.

    Let me explain what I'm doing, as I'm sure that will help. My long-term goal is to put together a basic "Kali Linux" package that can be installed via APT on Mobian (Debian Mobile). Obviously, before I do that I need to get each part working and become more familiar with everything. One of the first programs I'm trying to get to work is Fern WiFi Cracker because, I'm guessing, the WiFi tools may be some of the most used from a mobile phone. It actually uses many of the popular individual WiFi tools in concert with a GUI. I am expecting to have to remake a number of the GUIs and create "mobile-friendly" wrappers for others. So with all of that in mind, and considering the error message above, what would be the best way to try to solve this?

    https://github.com/savio-code/fern-wifi-cracker

    I really have only used JS in the past, but I've made a number of (terrible) web apps And I've fiddled around with Python a little bit so this is something I can figure out if I get put on somewhat of a straight course. I'm hoping someone here reads this and can help. I'm guessing what it's referencing are GUI-related packages the script calls and those packages are having some kind of conflict due to them being attempted to run on a mobile phone? It's a PinePhone to be more specific.

    Thank you and feel free to send me a PM. Any replies will be greatly appreciated. I could really use the input of someone more experienced here.



  • First of all, try not to use sudo since apart from being a bad practice it usually generates this type of problems.

    If it still doesn't work then run QT_DEBUG_PLUGINS="1" python3 execute.py and share the log:



  • @eyllanesc Alright, thank you. I'm also reading about making a qt.conf, does that sound like something that might work?

    https://lemirep.wordpress.com/2013/06/01/deploying-qt-applications-on-linux-and-windows-3/
    https://doc.qt.io/archives/qt-4.8/qt-conf.html

    Edit: Lol, I ran it without sudo and it's actually giving me different errors regarding import variables at specific line numbers. This is something that I can actually fix. It's always something dumb, lol. I appreciate the reply. I'm going to tool around with this more I think I'll eventually get it. I'm definitely going to check out the debug suggestion as well. I think I might actually be able to figure this out between everything I'm reading and what you suggested. Thanks!

    Edit:Edit: @eyllanesc , would you say that what is being describe here is at the core of my "problem"?

    https://askubuntu.com/questions/270006/why-should-users-never-use-normal-sudo-to-start-graphical-applications#270019

    I need to make it a point of understanding all the problems right now, otherwise I feel like I run the risk of developing a lot of bad habits.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    It's partially that. It also has to do with the fact that access to the graphics server is disabled by default to the root user for security reasons.


Log in to reply