[Tutorial] How to set up Urho3D (Shared, MinGW) in Qt Creator IDE

  • It is so simple to set up Urho3D-1.7.1 in Qt Creator IDE on Windows 10:

    1. Download and install Open Source Qt MinGW: https://www.qt.io/download-open-source
    2. Download and unzip " Urho3D-1.7.1-MinGW-SHARED.zip", for example, to "E:/Libs" folder
    3. Run Qt Creator and create a new project: "File" > "New File or Project" > "Other Project" > "Empty qmake Project" > click the "Choose..." button > type a name of project, for example: Urho3D_QtCreator > click "Next" > "Next" > "Finish"
    4. Create a "main.cpp" file and copy this code to it:
    #include <Urho3D/Engine/Application.h>
    #include <iostream>
    class MyApp : public Urho3D::Application
        MyApp(Urho3D::Context * context) : Urho3D::Application(context)
        virtual void Setup()
            std::cout << "Setup" << std::endl;
    1. Copy these settings to the .pro file:


    CONFIG += c++11
    INCLUDEPATH += "E:\Libs\Urho3D-1.7.1-MinGW-SHARED\include\Urho3D\ThirdParty"
    INCLUDEPATH += "E:\Libs\Urho3D-1.7.1-MinGW-SHARED\include"
    LIBS += -L"E:\Libs\Urho3D-1.7.1-MinGW-SHARED\lib\Urho3D"
    LIBS += -lUrho3D -lkernel32 -luser32 -lgdi32 -lwinspool -lshell32 -lole32 -loleaut32 -luuid -lcomdlg32 -lSetupapi -ladvapi32 -lwinmm -limm32 -lversion -lws2_32 -ldbghelp -lopengl32 -liphlpapi
    SOURCES += \
    1. Run the project by pressing on the green triangle button in left bottom corner (or Ctrl + R). You will see this error:
    2. To solve this error you need to copy two folders "CoreData" and "Data" from here “E:\Libs\Urho3D-1.7.1-MinGW-SHARED\share\Urho3D\Resources” to the "debug" folder where your .exe is located
    3. Run the project again and it works.

Log in to reply