Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problems with Adding Qt Library Packages via Maintenance Tool: ReferenceError



  • First of all, I am completely new to using Qt Creator so I do not have that much experience with it. I had downloaded version x86 4.0.1 on my Windows 10 computer very recently, but I discovered a problem with Qt Creator in that when I was trying to run a project it was saying that Kits were missing, and in trying to solve the problem with Kits I found out that the Qt version was being displayed as "None" according to the IDE. So, after reading some posts it seems that I was missing a Qt Library so I ran the Maintenance Tool in the Qt directory, successfully logged into my account, and selected version 5.9.3 to install (I had tried installing version 6 and above but it came up with a reference exception, similar to the one that I will describe). I hit Update and then at the 40% mark it shows an error which is the following:

    ReferenceError: registerQtCreaterDocumentation is not defined

    I try again and I receive the same error at exactly the same percentage mark. In such a case I do not know what to do when I am hit with this error when attempting to download and install a Qt Library. After I click "Okay" on the Error dialogue box it then takes me to the "Finished" tab where I cannot do anything else except try again (which has failed for me) or to quit the installer. I would be much obliged for assistance in this matter.


  • Moderators

    Try uninstalling Qt completely. Then run Qt installer again, and in package selection pick any Qt version you need, for example a build for MinGW compiler. Should work.



  • Thank you very much for that suggestion. It looks like resolving the problem truly was as easy as uninstalling Qt completely and then reinstalling it again. During the installation process, I selected the default option instead of custom installation and everything went fine. Additionally, the problem with Kits was also resolved.