Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Online installer crash - qt6_601_x86/2021-01-07-0831_meta.7z - server replied: Not Found



  • I tried installing Qt using the Qt Maintnance tool both using a GUI or using the CLI - the result is the same

    adi@spandauhome:~/Downloads$ ./qt-unified-linux-x64-4.0.1-1-online.run --accept-licenses --da --ao --confirm-command install qt.tools.ninja qt.tools.qtcreator qt.tools.cmake qt.qt5.51210.gcc_64
    [0] Arguments: ./qt-unified-linux-x64-4.0.1-1-online.run, --accept-licenses, --da, --ao, --confirm-command, install, qt.tools.ninja, qt.tools.qtcreator, qt.tools.cmake, qt.qt5.51210.gcc_64
    [1] Operations sanity check succeeded.
    [1] Reading Qt Account settings from disk: "/home/adi/.local/share/Qt/qtaccount.ini"
    [1] QtAccount information:
    [1] Login completed: false
    [1] Email: "<REDACTED>"
    [1] Total number of licenses: 0
    [1] Account type: 3
    [1193] Login completed to Qt Account: "<REDACTED>"
    [1586] Saving licenses to file: "/home/adi/.local/share/Qt/qtlicenses.ini"
    [1586] Saving Qt Account settings to file: "/home/adi/.local/share/Qt/qtaccount.ini"
    [1743] "Installation preconditions ok, installation can proceed!" [ "success" ]
    [3526] Open Source obligations accepted by user.
    [3526] No target directory specified, using default value: "/home/adi/Qt"
    [3526] Preparing meta information download...
    [10765] Retrieving meta information from remote repository...
    [11626] Warning: Network error while downloading 'https://download.qt.io/online/qtsdkrepository/linux_x64/android/qt6_601_x86/2021-01-07-0831_meta.7z': Error transferring https://download.qt.io/online/qtsdkrepository/linux_x64/android/qt6_601_x86/2021-01-07-0831_meta.7z - server replied: Not Found.

    I get the same error when using the GUI - looks like that file was updated today to https://download.qt.io/online/qtsdkrepository/linux_x64/android/qt6_601_x86/2021-02-02-0642_meta.7z, but the installer does not know about this. Any way I can fix this?

    -Adrian



  • Works now. Closing.


Log in to reply