Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installer retrieving the wrong meta file



  • I was trying to install a MSVC 2017 32-bit kit (or see what version of Qt has a 32-bit version to go along with the 64-bit MSVC 2017 kit and the QT Maintenance and Upgrade tool kept telling me it couldn't download one of the meta.7z files. So I moved the C:\Qt folder out of the way and downloaded a brand new Windows installer to see if I could start over from scratch.

    It also has trouble. I get "Network error while downloading https://download.qt.io/online/qtsdkrepository/default_install/2020-11-27-1311_meta.7z ... server replied: Not Found.

    So I typed that URL into a web browser, and sure enough, the proper meta.7z file is named: 2021-01-27-0717_meta.7z. I don't know why the installer is looking for the file from November, but maybe someone can correct whatever is wrong such that I can install Qt?

    FWIW, the previous Maintenance tool was looking for https://download.qt.io/online/qtsdkrepository/windows_x86/desktop/tools_maintenance/2020-12-03-0501_meta.7z. That URL contains a file named 2021-01-19-0655_meta.7z. Seemingly the same problem: the maintenance tool is looking for the wrong file.

    Thanks.



  • I seem to be having the same problem, but the installer actually fails when looking for the 2021-01-27-0717_meta.7z file, while the https://download.qt.io/online/qtsdkrepository/default_install/ page only contains a file named 2021-02-03-0935_meta.7z



  • I'm having the same problem. But the installer often looks for different files each time it starts. I've seen it look for 2021-01-07-0840_meta.7z. But if I restart it, then it looks for 2021-01-07-0841_meta.7z. And then if I restart once more, it looks for 2020-12-03-0501_meta.7z.



  • For what it's worth, what I wound up having to download the latest installer and install everything over again from scratch using the new --mirror option that the version 4 installer offers. No matter what I tried with the "maintenance" tool, I couldn't get it to successfully read metadata files from the QT server or other servers I tried by manipulating the server list in the Maintenance tool Settings. Even after installing from scratch with the new installer, the brand new Maintenance tool still didn't work.

    Here's the command I ran once I downloaded the new installer to download QT 5.14.2 for both 32 and 64-bit MSVC compilers (all on one line):

    Downloads\qt-unified-windows-x86-4.0.1-1-online.exe \
      --mirror http://mirrors.ocf.berkeley.edu/qt \
      --root C:\Qt_new \
      --accept-obligations \
      --default answer \
      in qt.qt56.5142.win64_msvc2017_64 qt.qt5.5142.win32_msvc2017 \
         qt.qt5.5142.src qt.tools.openssl.win_x86 qt.tools.openssl_win_x64 \
         qt.tools.openssl qt.tools.ifw40
    

    I figured out what I needed by using the old maintenance tool on the command line to show me what I already had (list argument), then used search with the new installer to figure out what I needed to add to get the 32-bit kit I lacked. Then I combined the two in a run of the new installer.


Log in to reply