Important: Please read the Qt Code of Conduct -

QT 4.8 doesn't show GUI style GTK+

  • Hello,

    I installed qt 4.8 from the sources on Ubuntu 11.04, 32 bit.
    If I use it to compile my application, they are slow and look ugly.
    The reason is the GUI style:
    With at 4.7 I use the GTK+ GUI style. It is selected for my user
    account, but not used for applications, compiled with QT 4.8.
    If I type:
    @cd /usr/local/Trolltech/Qt-4.8.0/bin
    then the GUI style GTK+ is not offered in the dropdown box.
    If I use qtconfig, that comes with Ubuntu (from qt 4.7) it is offered,
    but these settings are not used by qt 4.8 applications.

    How can I fix this?

    Best regards:

    Uwe Fechner

  • Well, are you sure that the GTK style was compiled? You should have seen that when running configure. Try to see if src/gui/Makefile contains styles/qgtkstyle.cpp in the source files (or instead if it defines QT_NO_STYLE_GTK).

  • Hi,
    yes, it contains styles/qgtkstyle.cpp in the source files.

    Any other idea?


    Uwe Fechner

  • You built Qt 4.8 yourself it seems. If configure cannot find the libs/headers from the GTK+ devel packag, it will not build the style, but do so silently. it will only error out if you force the style (./configure -gtkstyle). The presence of styles/qgtkstyle.cpp is no indication that it's actually being compiled in.

Log in to reply