Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

"Qt quick emulation layer crashed" in Qt Creator's Design Tab



  • This message appears in any new QtQuick project, in examples too.

    Qt 6.0.0 / 6.0.1
    Qt Creator 4.14
    OS: Windows 10 20H2

    CPU: Intel Core i5 3470
    GPU: Nvidia Geforce GTX1050Ti (GameReady or Studio drivers) or Intel® HD Graphics 2500 have same issue.
    RAM: 16GB

    Screenshot 2021-01-23 132121.png



  • The same issue on Ubuntu.

    Qt 6.0.0 / 6.0.1
    Qt Creator 4.14
    OS: Ubuntu 20.04.1 LTS

    1. Open Qt Creator
    2. File -> New File or Project
    3. Application (Qt Quick) -> Qt Quick Application Empty
    4. Build System CMake
    5. Minimal required Qt version: Qt 5.15 // Why I can't choose 6.0??
    6. Open main.qml in Designer
    7. Select Form Editor tab in the Designer
    8. Error window shows



Log in to reply