[Solved] qtwinmigrate-2.8_1-opensource install trouble



  • When I did make for qtwinmigrate-2.8_1-opensource, ld error happened as described under.
    Please let me advise.( I wrote my procedure after error messages.)

    g++ -enable-stdcall-fixup -Wl,-enable-auto-import -Wl,-enable-runtime-pseudo-rel
    oc -mthreads -Wl -Wl,-subsystem,windows -o debug\winwidget.exe debug/main.o debu
    g/qwinwidget.o debug/qwinhost.o debug/qmfcapp.o debug/moc_qwinwidget.o debug/moc
    _qwinhost.o -L"c:\Qt\2010.05\qt\lib" -lmingw32 -lqtmaind -luser32 -lQtGuid4 -lQ
    tCored4
    c:\Qt\2010.05\qt\lib/libqtmaind.a(qtmain_win.o): In function WinMain@16': C:\qt-greenhouse\Trolltech\Code_less_create_more\Trolltech\Code_less_create_more \Troll\4.6\qt\src\winmain/qtmain_win.cpp:131: undefined reference toqMain(int,
    char**)'
    collect2: ld returned 1 exit status

    my procedure

    1. install qt-sdk-win-opensource-2010.05
    2. locate qtwinmigrate-2.8_1-opensource at C:\Qt\2010.05
    3. comment out L10 at C:\Qt\2010.05\qtwinmigrate-2.8_1-opensource\src\qtwinmigrate.pri
      because I use VS2008 express.
    4. cd C:\Qt\2010.05\qtwinmigrate-2.8_1-opensource at command prompt
    5. add path C:\Qt\2010.05\qt\bin;C:\Qt\2010.05\mingw\bin
    6. qmake
    7. mingw32-make


  • Hi Jackbauer_777 (good nickname :-)

    Did you solve that since your post?
    If not, maybe it is a good idea to "report your issue":http://bugreports.qt.nokia.com/ in project Qt Solutions, components MFC migration.



  • Copy that!
    Thank Mr.anselmolsm for your kind reply.

    When I compiled Qt by VC2008express, I didn't meet above trouble.

    So This problem was solved for me^^;



  • Hmm sorry for the thread dig up...

    I still have that trouble, using QTCreator :/ couldn't find the reason, damnit!

    Anyone have a clue?

    It seems the linker can't find the "main" entry point function. There is indeed not such a function in the "main.cpp".

    Instead, we have the following:
    @int APIENTRY wWinMain(HINSTANCE hInstance,
    HINSTANCE /hPrevInstance/,
    LPTSTR /lpCmdLine/,
    int nCmdShow)@

    Anyone could help me on how to fix this?
    (I'm newbie with Win32 API....)

    D'oh! Just realized this thread was marked as [Solved]..... plz mod tell me if I must make a new one or if I can hijack this one :p



  • Nevermind my last post, I don't need it anymore as I found a way to do what I needed. :)



  • Hello Radek,

    Can you explain how did you solve your problem ? I'm facing the same issue and I didn't find any solution after two days of research. So your help will be welcome.

    Thanks in advance

    [quote author="Radek" date="1318584721"]Nevermind my last post, I don't need it anymore as I found a way to do what I needed. :)[/quote]



  • Hello Gojir4,

    I don't quite remember if I really did something about this issue (sorry but it's quite old...). I think I've found another way for what I needed to. I didn't use the QtWinigrate in the end...

    I think that sort of error appears when you already have a win32API entry point declared somewhere and you want to compile another one in the same batch.... not totally sure though.

    Good luck in finding a solution.

    Radek.



  • Hello Radek,

    Thanks for your reply.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.