Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

15.5.2 and visual studio 2019x64



  • Hi,

    I have this problem that only manifests itself with Qt5.15.2. If I build a simple app with a QPushButton it fails to launch from the desktop (with and without windeployqt invoked) BUT it will run fine from QtCreator. Same app in 14.9 works as expected. The screen shot shows what happens when I use mousebutton example in Examples provided. I build it with creator and then start from finder.
    QPushButton.png


  • Lifetime Qt Champion

    Hi
    One reason could be you have another app build with Qt that has added its folder to the global path so
    a wrong Qt dll is found and loaded.

    you could use a tool like
    https://github.com/lucasg/Dependencies

    and see where the dlls are loaded from.

    You could also use a virtual windows 10 to test in and see.



  • Thanks. I used dependencies and was able to solve the problem.

    For others I attach a screen shot. It shows that even though I configured Qt to use 5.15.2 the exe created was pulling in the 5.12.9 dll's (which were missing the symbol). The fix I used was to change my env settings PATH variable to point to the 5.15.2 bin dir as opposed to the 5.12.9 dir so that it was using 5.15.2 qmake. Still not sure why it worked from QtCreator before, bit it now works for both QtCreator and when launching from terminal.

    thanks again

    DependencyQt.png


Log in to reply