Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Design Studio shut down suddenly



  • Hi everyone,

    I've a project developed in QT Design Studio (version before the current one).
    After update it to the last version, i cannot simply open my UI files that contains animations and modify them.

    Everytime I open the file, the program crashes and goes down.

    I have tried to understand what is causing the problem and figured out that if the following code is commented, the UI file opens without problems.

    KeyframeGroup {
                target: loginScreen_Base
                property: "opacity"
                Keyframe {
                    frame: 0
                    value: 0
                }
    
                Keyframe {
                    frame: 674
                    value: 1
                }
            }
    

    I've executed it using Terminal and when the program crashes, I get the following error:

    QFileSystemWatcher::removePaths: list is empty
    QFileSystemWatcher::removePaths: list is empty
    Exception: "InvalidPropertyException"
    Function:  "parentProperty"
    File:      "/Users/qt/work/build/qt-creator/src/plugins/qmldesigner/designercore/model/modelnode.cpp"
    Line:      381
    "file: /Users/qt/work/build/qt-creator/src/plugins/qmldesigner/designercore/model/modelnode.cpp, function: parentProperty, line: 381"
    
    libc++abi.dylib: terminating with uncaught exception of type QmlDesigner::InvalidPropertyException
    [24289:647800:20201228,183653.987186:WARNING crash_report_exception_handler.cc:240] UniversalExceptionRaise: (os/kern) failure (5)
    Abort trap: 6
    

    I've already reinstalled the entire qt suite a couple of times, and I always get the same error.
    I've also tried with a new project, but as soon as I start to use animations, the program crashes with that error.
    I've tried also the Windows version (I've been using MacOS) and the problem persists.

    I know that I can always skip animations and develop a simple UI, but I rather not do it.

    So, if you have any other suggestion, or a possible solution to this, please, help me out to figure what is causing this!

    Info about my QT Design Studio:

    Qt Design Studio 2.0.0
    Based on Qt 5.15.2 (Clang 11.0 (Apple), 64 bit)
    
    Built on Dec 17 2020 15:44:57
    
    From revision 45b35d29fb
    

    Thank you!


Log in to reply