Problems with Open-Source Downloads read https://www.qt.io/blog/problem-with-open-source-downloads and https://forum.qt.io/post/638946

Can't Add/Build module in QT15.13.2 on ARM64 ( error: static assertion failed)



  • Hi,

    • I want to run a QT application on an ARM64 architecture.
    • I am developing on an Ubuntu 16 virtual machine, and I installed QT with the ARM64 cross compilers by following the following link: Qt5.13.2 Instalation
    • I Download cross compiler from aarch64 sources
    • The directory of my installation is in /usr/local/qt-everywhere-src-5.13.2
    • Then I installed the executable of Qt Creator with qmake desktop for development.
    • then i configured a new kit in qt creator cross compiler for the AMR64 architecture.

    conf compilators :
    c++.jpg
    c.jpg

    conf Qt Version:
    qtv.jpg

    conf Kits :
    kit.jpg

    I had trouble getting some examples to work at the start because in the build / project menu there was no make but I inserted it directly into the "make / usr / bin / make" form

    I finally managed to compile some example with the arm64 kit I created, but as soon as I need to use a new library, I crash, and so I tried to download and build a modulethat I needed by following the next steps:

    git clone https://github.com/qt/qtserialport.git
    cd qtserialport
    mkdir build
    cd build
    /usr/local/qt-everywhere-src-5.13.2/bin/qmake ../qtserialport.pro
    

    result :
    qt1.jpg

    but in the last step it's faild :

    make
    

    qt2.jpg

    from /home/xx/xx/source_instalation/qtserialport/src/serialport/qserialportinfo_unix.cpp:42:
    /usr/local/qt-everywhere-src-5.13.2/include/QtCore/qglobal.h:121:49: error: static assertion failed: Required feature library for file /usr/local/qt-everywhere-src-5.13.2/include/QtCore/qlibrary.h not available.
     #  define Q_STATIC_ASSERT_X(Condition, Message) static_assert(bool(Condition), Message)
                                                     ^
    /usr/local/qt-everywhere-src-5.13.2/include/QtCore/qglobal.h:87:36: note: in expansion of macro ‘Q_STATIC_ASSERT_X’
     #define QT_REQUIRE_CONFIG(feature) Q_STATIC_ASSERT_X(QT_FEATURE_##feature == 1, "Required feature " #feature " for file " __FILE__ " not available.")
                                        ^~~~~~~~~~~~~~~~~
    /usr/local/qt-everywhere-src-5.13.2/include/QtCore/qlibrary.h:45:1: note: in expansion of macro ‘QT_REQUIRE_CONFIG’
     QT_REQUIRE_CONFIG(library);
     ^~~~~~~~~~~~~~~~~
    /home/xx/xx/source_instalation/qtserialport/src/serialport/qserialportinfo_unix.cpp: In function ‘bool isRfcommDevice(QStringView)’:
    /xx/xx/JPB/source_instalation/qtserialport/src/serialport/qserialportinfo_unix.cpp:160:44: error: ‘class QStringView’ has no member named ‘toInt’
         const int portNumber = portName.mid(6).toInt(&ok);
    
    

    I had the same error when I installed QT for ARM64 , and I really don't know what to do to add new module, can you help me please?


Log in to reply