[Solved]Qt Creator compiled with mingw autodetects SDK qmake directories but I uninstalled them



  • Okay so I wanted to install Qt compiled with mingw and to compile QtCreator with mingw (see http://developer.qt.nokia.com/forums/viewthread/12461/) and managed to do that. However, when I look in TOOLS->OPTIONS->Build & Run and the Qt Versions tab the auto-detected show all of the sdk linkages to qmake.exe

    I did originally have the SDK installed on my computer but uninstalled it prior to installing the Qt libraries and Qt Creator. I was able to manually add the path C:\qt\4.7.4\bin\qmake.exe and compile and run my little GUI that I made. So that's cool.

    But I would like for it to say Qt in PATH and show the same as the one I put in manually (then I wouldn't need the manual one).

    So my questions are
    1)why has it used auto-detected SDK settings that dont exist anymore?
    2)how do I delete them?
    3)how do I get the correct Qt path to auto-detect?
    4)did I frig up my Qt and QtCreator install?



  • 23 views over 9 hours. Makes me think there is some interest......
    but.......not a word was heard....



  • whshhhhh......tumbleweed......whshhhhhh.....tumbleweed

    seriously has this never happened to anyone before?



  • Patience is a virtue, I am quite sure none of the people who looked at your thread walked away, knowing the answer to your question without sharing it.

    Anyway, I think the Qt SDK is compiled with mingw by default and uses mingw by default, why are you going through all that unnecessary acrobatics to begin with? Use the Qt maintain tool - I have used it to update my SDK over a few iterations of many of its tools and it's all good.

    Are you sure you cleaned all old Qt related settings from your OS environment variables? Besides adding Qt directories to the system PATH there is also a QMAKESPEC environment variable.



  • [quote author="ddriver" date="1323905763"]Anyway, I think the Qt SDK is compiled with mingw by default and uses mingw by default[/quote] You are correct partially, while designer is compiled with mingw in the SDK the creator is not. It is compiled with MSVC.

    Normally I guess this would not be a problem, but I REALLY need plotting functionality in my GUI. I am recreating a GUI/app that I created in a different language. The only real available package is QWT (that wont cost me bucks). And if I want to use this in creator my understanding is that you should compile it in mingw. Maybe I will have to try and compile it in MSVC...but the various posts that I have seen, appear to me the complete noob, to be just a treacherous as the mingw route. I did try once before but didn't understand jack about the compiler output.

    [quote author="ddriver" date="1323905763"]Are you sure you cleaned all old Qt related settings from your OS environment variables? Besides adding Qt directories to the system PATH there is also a QMAKESPEC environment variable.[/quote] I will double check.

    Cheers



  • Well the solution in this case is just a hack..but I can live with it

    I reinstalled the SDK and the auto-detect now see those qmake libs it was looking for


  • Moderators

    Auto detection of the SDK stuff works by looking into share/qtcreator/Nokia/. Move that directory out of the way and you should be fine. Not installing your custom Qt Creator over the Qt SDK one might also help:-)



  • Hi Tobias,

    The custom Qt Creator isn't installed over the SDK creator. It isn't even in the same directory. It sits in the mingw Qt directory separate from the SDK altogether. My confusion comes from the fact that the Qt and Qt Creator I installed even see's or knows that the SDK is there.

    I will try and move the directory you mentioned.

    Cheers


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.