Important: Please read the Qt Code of Conduct -

Qt Creator Settings file

  • Hello everyone,

    I decided to ask my question here today because i have some problems with my QtCreator.

    I tried the one that comes with the 5.14.2 and 5.15.2 and i have the same issue.

    The problem is that QtCreator Works well on first launch only.
    If I closed it and launch again it stuck at updating documentation and i need to reboot the computer in order to close it (no other way to close i tried everything).

    I work on a windows 10 laptop working under a company security setup. I think that the problem is due to my user folder being crypted.

    So on first start QtCreator can create his settings folder in "%SystemDrive%\Users%USERNAME%\AppData\Roaming\QtProject"
    But could not reload it afterward due to encryption (this is my assumption, it could be wrong).

    My question, is there any way to relocate this settings folder to a non encrypted area ? I think this is the first thing i should try.

    Thanks in advance for your answer and sorry if my english isn't perfect but i'm french.


  • Lifetime Qt Champion

    Dear @Jacques_NM18, welcome!

    Indeed you can change the location of the settings by running Creator with the command line option -settingspath xxx.

    So for testing, you can just create a shortcut with that option pointing to another (empty) directory and see if that helps.

    Best regards

  • Hello @aha_1980,

    Thanks for your very quick answer.

    What you give did exactly what i wanted.

    Unfortunately it seems like i was wrong... Even with settings in a folder doesn't covered by encryption or save utilities i could not relaunch the Creator.

    I will take contact with my IT support to try it with the Anti-Virus disable. Maybe it could be him who causes my problem.

  • Lifetime Qt Champion

    Hi @Jacques_NM18,

    yes, disabling AV might help. Maybe you can get an exception for the folder where the settings are stored.

    Otherwise I'm running out of ideas...


Log in to reply