Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox



  • Hello,

    I have created an Bluetooth Low Energy Application on Windows 10, that works finde. Not I want to try this application on Linux, but I do not have a linux PC, so I installed the VirtualMachine and the Ubuntu 20.04.1 OS. I've never worked with Linux before, so I tried a tutorial where I downloaded the Online Installer, then I started it, chose under "Qt 5.15.1" the "Desktop gcc 64-bit" and under "Developer and Designer Tools" I chose the default "CMake 3.17.1" and "Ninja 1.10.0" and installed Qt and the Qt Creator. So After clicking on "Finish", the Qt Creator should have started automatically, but there was this error:

     Could not load the Qt platform plugin "xcb" in "" even though it was found.
    

    Then I installed other development tools like it is written in the documentation with

    sudo apt-get install build-essential libgl1-mesa-dev
    

    So then, I tried to launch Qt Creator by clicking on the icon, but nothign happens.
    When I try it out from the terminal with ./qtcreator, this appears

    bash: ./qtcreator: No such file or directory
    
    

    So what might be the problem here?


  • Moderators

    @TUStudi Great!

    Install the library that is "not found" and you'll be able to run Qt Creator.


  • Moderators

    @TUStudi said in Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox:

    there was this error:

     Could not load the Qt platform plugin "xcb" in "" even though it was found.
    

    That means you have a missing dependency.

    Go to the directory where you installed Qt Creator and look for plugins/platforms/libqxcb.so. Use the ldd command to see which dependency is "Not found".

    > ldd libqxcb.so

    bash: ./qtcreator: No such file or directory
    

    ./ means "my current directory".



  • @JKSH said in Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox:

    That means you have a missing dependency.

    Go to the directory where you installed Qt Creator and look for plugins/platforms/qxcb.so. Use the ldd command to see which dependency is "Not found".

    I cannot found the qxcb.so file. there areonly these files in the directory platforms:

    77277028-4b9f-4863-b97d-39614437c4e4-image.png


  • Moderators

    @TUStudi said in Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox:

    I cannot found the qxcb.so file.

    Sorry, I meant libqxcb.so



  • @JKSH said in Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox:

    @TUStudi said in Qt Creator does not launch on Ubuntu 20.04.1 in VirtualBox:

    I cannot found the qxcb.so file.

    Sorry, I meant libqxcb.so

    linux-vdso.so.1 (0x00007ffefeb98000)
    	libQt5XcbQpa.so.5 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libQt5XcbQpa.so.5 (0x00007fef9ce58000)
    	libfontconfig.so.1 => /lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007fef9ce00000)
    	libfreetype.so.6 => /lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007fef9cd41000)
    	libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007fef9cd25000)
    	libQt5Gui.so.5 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libQt5Gui.so.5 (0x00007fef9c3f4000)
    	libQt5DBus.so.5 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libQt5DBus.so.5 (0x00007fef9c168000)
    	libQt5Core.so.5 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libQt5Core.so.5 (0x00007fef9b970000)
    	libGL.so.1 => /lib/x86_64-linux-gnu/libGL.so.1 (0x00007fef9b8e8000)
    	libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007fef9b8c5000)
    	libX11-xcb.so.1 => /lib/x86_64-linux-gnu/libX11-xcb.so.1 (0x00007fef9b8c0000)
    	libxcb-icccm.so.4 => /lib/x86_64-linux-gnu/libxcb-icccm.so.4 (0x00007fef9b8b9000)
    	libxcb-image.so.0 => /lib/x86_64-linux-gnu/libxcb-image.so.0 (0x00007fef9b6b4000)
    	libxcb-shm.so.0 => /lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007fef9b6ad000)
    	libxcb-keysyms.so.1 => /lib/x86_64-linux-gnu/libxcb-keysyms.so.1 (0x00007fef9b6a8000)
    	libxcb-randr.so.0 => /lib/x86_64-linux-gnu/libxcb-randr.so.0 (0x00007fef9b695000)
    	libxcb-render-util.so.0 => /lib/x86_64-linux-gnu/libxcb-render-util.so.0 (0x00007fef9b68e000)
    	libxcb-render.so.0 => /lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007fef9b67f000)
    	libxcb-shape.so.0 => /lib/x86_64-linux-gnu/libxcb-shape.so.0 (0x00007fef9b67a000)
    	libxcb-sync.so.1 => /lib/x86_64-linux-gnu/libxcb-sync.so.1 (0x00007fef9b66e000)
    	libxcb-xfixes.so.0 => /lib/x86_64-linux-gnu/libxcb-xfixes.so.0 (0x00007fef9b664000)
    	libxcb-xinerama.so.0 => not found
    	libxcb-xkb.so.1 => /lib/x86_64-linux-gnu/libxcb-xkb.so.1 (0x00007fef9b646000)
    	libxcb.so.1 => /lib/x86_64-linux-gnu/libxcb.so.1 (0x00007fef9b61c000)
    	libXext.so.6 => /lib/x86_64-linux-gnu/libXext.so.6 (0x00007fef9b607000)
    	libX11.so.6 => /lib/x86_64-linux-gnu/libX11.so.6 (0x00007fef9b4c8000)
    	libxkbcommon-x11.so.0 => /lib/x86_64-linux-gnu/libxkbcommon-x11.so.0 (0x00007fef9b4bd000)
    	libxkbcommon.so.0 => /lib/x86_64-linux-gnu/libxkbcommon.so.0 (0x00007fef9b47b000)
    	libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007fef9b475000)
    	libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007fef9b294000)
    	libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007fef9b145000)
    	libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007fef9b128000)
    	libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007fef9af36000)
    	libxcb-xinerama.so.0 => not found
    	libgthread-2.0.so.0 => /lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007fef9af31000)
    	libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007fef9ae08000)
    	libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007fef9add8000)
    	libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007fef9adcf000)
    	libpng16.so.16 => /lib/x86_64-linux-gnu/libpng16.so.16 (0x00007fef9ad97000)
    	libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007fef9ad46000)
    	libicui18n.so.56 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libicui18n.so.56 (0x00007fef9a8ad000)
    	libicuuc.so.56 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libicuuc.so.56 (0x00007fef9a4f3000)
    	libicudata.so.56 => /home/techuni/Qt/5.15.1/gcc_64/plugins/platforms/./../../lib/libicudata.so.56 (0x00007fef98b10000)
    	/lib64/ld-linux-x86-64.so.2 (0x00007fef9d3b5000)
    	libGLdispatch.so.0 => /lib/x86_64-linux-gnu/libGLdispatch.so.0 (0x00007fef98a58000)
    	libGLX.so.0 => /lib/x86_64-linux-gnu/libGLX.so.0 (0x00007fef98a24000)
    	libxcb-util.so.1 => /lib/x86_64-linux-gnu/libxcb-util.so.1 (0x00007fef9881e000)
    	libXau.so.6 => /lib/x86_64-linux-gnu/libXau.so.6 (0x00007fef98816000)
    	libXdmcp.so.6 => /lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007fef9880e000)
    	libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007fef9879b000)
    	libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007fef986ee000)
    	libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007fef986d4000)
    	librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007fef986c7000)
    	liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007fef9869e000)
    	liblz4.so.1 => /lib/x86_64-linux-gnu/liblz4.so.1 (0x00007fef9867d000)
    	libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007fef9855f000)
    	libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007fef9853c000)
    
    

  • Moderators

    @TUStudi Great!

    Install the library that is "not found" and you'll be able to run Qt Creator.



  • @JKSH Thank you very much! That worked.


  • Lifetime Qt Champion

    Hi @TUStudi,

    just to add that this problem is tracked as QTCREATORBUG-24561.