Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator: Cannot change Qt Version



  • Hello, i upgraded my ubuntu 18 to ubuntu 20 and i suppose some of the qt paths or something like that didn't update, so now when i want to select new auto detected qt version i got the error:
    Cannot update Qt version information: /usr/lib/x86_64-linux-gnu/qt4/bin/qmake cannot be run.

    please see the attached image:
    qtcreatorr.png



  • @Kyeiv said in QtCreator: Cannot change Qt Version:

    Cannot update Qt version information: /usr/lib/x86_64-linux-gnu/qt4/bin/qmake cannot be run.

    Two things here:

    1. Most important: do you still need Qt 4?
    2. If answer to #1 is Yes, please check why qmake (from Qt 4 release) cannot be run (from a terminal I'd run the qmake command).
      Is it in that same location after OS upgrade? Is any required library missing after OS upgrade?

Log in to reply