.exe file doesn’t start



  • Hey.
    I got a big problem.
    First I want to say I'm new here and if you need more information or so, please just say.

    My problem is, when I create an .exe file of my project and I start it, nothing happens.
    No gui showing up, no error that a .dll is missing. Just nothing.
    This problem occurs with every programm. Even with the examples of Qt.

    I'm running Windows 7 64-bit.
    QtCreator 2.3.0
    Qt 4.7.4 (32bit)

    Hope someone could help me.
    Thank you very much.

    Regards Weed


  • Moderators

    Welcome to this forum.

    Looks like your environment is not set up properly.
    You need to provide more information on how you have created your setup.
    How did you install qt creator?
    Did you follow some instructions?

    What are the error message during compilation, if any?
    What are the messages when starting your application?



  • I downloaded the Qt Offline Installer and just installed it.

    My steps to build are:
    qmake
    clean
    build

    Compile Output:
    http://dl.dropbox.com/u/36957584/CompileOutput.txt
    I put it into a text file.

    When I start the application nothing happens.
    I changed it to run in terminal and after that the command prompt showed up on start for one second and disappeared then.


  • Moderators

    The compilation output does not show anomalies. I have seen that you are compiling in release mode. You might want to change to debug mode (under projects).
    Then you can run your programs in the debugger and find out where exactly it stops.

    You are running in terminal. What do you mean with that?
    Do you open a command prompt window and start the executable from the command prompt?
    Did you try to run a simple hello world program?



  • If I run the programm in the QtCreator I don't have any problems.

    With "running in terminal" I mean, under Projects->Run you can change "Run in terminal".
    When I start the programm a terminal window shows up and if the programm sends a message with "cout" it shows the message in this terminal window.
    But this only works in QtCreator.

    Yes, I tried everything. In QtCreator every programm runs fine but if I build a .exe and run it, nothing happens.


  • Moderators

    It is good that your program is running fine in qt creator.
    Your compile output shows that you are creating an application "cpp_web.exe". When you run it in creator, you are starting this executable. If the application does everything allright in the creator, that is good news.

    How do you start this executable outside of the creator?
    You need to make sure that you are starting the correct exe. Sometimes one is changing the compilation setup and starting a leftover exe. So better check the creation date and time of the exe.



  • I just navigate in the explorer to the project folder and inside this folder there is a folder named "release" with the .exe in it.
    I simply double-click it.
    Yes it's always the right one.


  • Moderators

    Does your application really have a GUI already?

    It is a bit strange that you do not get any error message as you have already written in starting your post. The only explanation I have at the moment is that you are not starting the GUI. However, you state that the application (including the gui) works fine in qt creator.



  • Yes it has.
    Do you want to see my source code?
    Here's the project folder:
    http://dl.dropbox.com/u/36957584/cpp_web.zip


  • Moderators

    I have no explanation for your problem.
    I am running windows 7 64 bit, but with msvc2005. So starting your exe results in an error message that mingw*.dll is missing. That was clear.
    Compilation and starting in the msvc starts in the debugger normally, a browser appears. Starting the exe externally the same thing. No problems at all.

    Maybe you have some problems with the installation and should reinstall.



  • Ok.
    Should I consider some important points?
    Or just reinstall?


  • Moderators

    I guess that this might be a problem with the mingw compiler installation. However, I do not have any experience there. Maybe there are some environment settings (like path), which you have not seen during installation. Maybe there are others. So watch out for any details there and follow. But those are only blind guesses.



  • Ok I'll try later when I'm home.
    Thanks (:


  • Moderators

    Good luck !!



  • Now I reinstalled QtCreator.
    The projects which run in the command prompt are working but the GUI projects not.
    The GUI doesn't show up.

    Someone an idea?


  • Moderators

    Hi there,
    I am wondering why you installed only qt creator but not the whole suite?
    Since in the creator was working, but it did not outside there must be probably something with the normal setup.
    Speaking about the environment. Do you have an version of Qt installed? Or do you have an application using old Qt libs installed? However, you should see an error message then, but that might be a reason.



  • you reinstall it



  • Sorry I meant i reinstalled the whole QtSDK kit



  • Push Push Push
    Still got the problem!



  • Yes, i got the same problem.
    I have a desktop open gl project and i'm trying to deploy it for windows.
    I copied all required .DLL files next to the .exe file. (Release build)
    The program starts and runs fine on my workstations but only on machines which have Qt5 Desktop OpenGL(self compiled) installed!
    Other machines (even those who have the normal Qt5.0.0 installed) wont start the program! It starts and stops again and you don't see anything. Sometimes one can see the window frame and then the application crashes... Do i miss smth.?



  • Place the libEGL.dll into the exe's folder.

    In my case that helped. I'm still having the same problem when i want to run the exe on other computers. But at least it works so far on mine.

    Any ideas?



  • okey i found a solution.

    • place all the dll's the program is asking for in your directory
    • place LibEGL.dll in your directory
    • create a new folder named "platforms"
    • place "qminimal.dll" and "qwindows.dll" in that folder

    start your exe


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.