Important: Please read the Qt Code of Conduct -

How do we import a skinned mesh, with armature, skeleton, and material from blender to Qt3d?

  • Everything is in the title.
    I'm able to import a 3D mesh, but in order to make it bend or move, we need armature and skeletons, the project I want to achieve is exactly like this one, :
    I'm trying to reproduce it using my own armature objects, but I can't. Actually this project not only imports skeleton and armature, but also animations, and you end up with a walking robot,
    I want to recreate it using my own objects (another type of robot for example), I try to skip the animation part in order to deal with the rendering first, and start by importing only the skinned mesh, but I can't make it work, I try to learn from the code of the example, but couldn't do it for more that 10 days,

    Did you try something similar using your own blender objects? any example, any friend of a friend who may have tried something similar, suggestion, link is appreciated.

  • I used QtQuick3D with Blender Model with Animation.

    What is the exact question?

  • To correct myself I used animations without bones, means the animation was done with timelime.

  • @Shazter A robot kind of mesh, moving without an armature ? is it possible?
    My goal is to load a robot with its animation from blender to Qt, but I thought that you have to have an armature, composed of bones, in order for it to move.

  • As mentioned I used QtQuick3D, is not Qt3D.

    Do you want to playback only the created animations in blender?
    If, yes then is possible in Qt5.15 (I tested in Qt Design Studio) by importing GLTF2 file from Blender. I had one issue with a Bug How the GLTF2 is imported and Qml File. I corrected the values by hand, then I was able to playback my animation.

  • I want to test that, how did you do it?

  • I had not a complex Model. I have uploaded my files to QT Jira to report a bug.
    Maybe it helps for your project.

  • I've never used Qt 3DS, How shall I execute your project, can I do it with Qt creator?
    QML module not found (Qt Quick.Timeline)

  • Use Qt Maintenance Tool and install Qt5.15 (includes Timeline Module and QTQuick3D) and Qt Design Studio Community Version if you have no commercial license, its not Qt 3D Studio.

    Please Qt Manuals for more Informations.

  • I get this when I run you project with Qt DS,

    Apparently you can use qt 3D studio, not for creating 3D, but aploading 3d and adding user interfaces, exactly what I want.

  • @sofiane Is a bug and you have to fix it manually the Problem is described very well in the image

    You have to change the value in the file Anitest.qml Line 69 from double to int value.
    Looks like your are a full beginner may you start to do your homework with tutorials first, instead big and complex projects.

  • Yes, I've never worked with Qt DS, I just want to execute an example to see what it does. I get the following errors after changing to int:

    QSSG.invalid_operation: Vertex compilation output:: 0:1(10): error: GLSL 3.10 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.40, 1.00 ES, and 3.00 ES
    QSSG.invalid_operation: Vertex compilation output:

    Even the examples I find in internet aren't clear, they just start with an already completed example.

  • This Problem I did not occurred on my PC, but from the error message I guess you have OpenGL 3.10 installed and it works only looks 1.10, 1.20, 1.30, 1.40, 1.00 ES, and 3.00 ES.

  • Qt Delevoper updated some Demos for QDS 1.6, but looks like it works for 1.5 too.
    Here a Image of the QML Scene with QDS 1.5


    You have to clone with GIT LFS, otherwise Big files are missing.

    git lfs clone

Log in to reply