Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt Creator's Design Tab keeps giving me "Line 1: Qt Quick emulation layer crashed." error.



  • I already tried that one workaround where I have to remove the check on "Always use the QML emulation layer proved by Qt Creator" but because I am on the latest version, that option is nowhere to be found. Unless it's been moved, changed name, or something.

    I already tried to use the "Use QML emulation layer that is built with the selected Qt" without changing the directory. (It doesn't work) and using it with any directory, just regenerate the same qmlpuppet.exe.

    I tried updating the Qt version I use from 5.9 to 5.15. It still doesn't work. I also have the latest Qt Creator 4.12.4

    I tried reinstalling all the components (~30GB) and it was infuriating. Lmao. (It still doesn't work)

    Some info: The build project and run project function works fine and does not give me any error. I'm sure I have the latest Qt version but only for the windows part. I have all the components of Qt Creator except the 3d parts. I also have a Qt designer studio software installed alongside Qt creator which is virtually the same but have maybe reduced functionality. (I'm not yet sure) (it also has a broken design tab)

    I also have the open-source version if that matters.

    Some help would be appreciated. Thank you.


Log in to reply