[Solved] Choosing MSVC toolchain



  • Hi guys.
    I want to use QtCreator and MSVC as a compiler instead of MinGW. I successfully compiled Qt source code with MSVC 2010. As you would have guessed, I have MSVC 2010 installed on my machine. I also registered MSVC version of Qt in QtCreator, but now the problem is that I can't select MSVC toolchain in qtcreator.
    So far, I found out that QT_INSTALL_LIBS and QT_INSTALL_BINS are not correctly configured for MSVC version of qt binaries. I guess this could be the problem, but I don't know how I should configure that variables.

    Here's the screenshot http://dl.dropbox.com/u/3055964/Untitled.gif

    Your help is much appreciated.
    Thanks



  • I guess from your screenshot that you're using Qt Creator 2.2 or 2.3. Did you try using the 2.4 release candidate available "here":/wiki/Qt_Creator_Releases?



  • Thanks Volker. I just installed the 2.4 RC version of QtCreator, but it didn't help at all. I tried removing and adding again the MSVC Qt version in the ide but I've got same results. How does QtCreator assigns value to QT_INSTALL_LIBS and QT_INSTALL_BINS? Maybe I can correct it by hand if I find it. I mean, when I select qmake.exe for msvc libraries, qtcreator automatically assigns incorrect pathes.
    Thanks again


  • Moderators

    Try running "qmake -query", that is what we use to find the Qt install location, etc.

    PS: Which tool chains are offered does depend on the QtCore library. We look at it and try to find out what it will work for.



  • Damn, I just remembered that during configuration phase, configure.exe couldn't copy qmake.exe to the bin directory, so I accidentally copied the one compiled with mingw. Probably this should be the problem. I will try to rebuild qt with the correct qmake and post the result here.
    BTW, those variables, QT_INSTALL_LIBS & QT_INSTALL_BINS are hardcoded in qmake? I mean, they are assigned during compilation phase?



  • These values are hardcoded in to qmake. The acutal value depends on the prefix options etc. So, using qmake.exe from the MinGW build is causing the trouble. BTW - that would mangle compilation on the command line too!



  • Thanks guys. We were right, the problem was qmake compiled with mingw. I successfully recompiled my project with MSVC toolchain :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.