Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QT 5.15.0 install :



  • @hskoglund I tried to launch gdb.exe whickh is in codeblocks in command line to see if it works. Inoted also that gdb.exe in codeblocks is exactly the same as in Qt. To test gdb, i used a small program prog.c:

    #include <stdio.h>
    #include <stdlib.h>

    int main()
    {
    printf("Hello world!\n");
    return 0;
    }

    The i compiled it with :

    gcc -Wall -g prog.c -o prog

    and after i launched :

    gdb prog.exe

    And the result is that i have nothing.
    I made the same thing with gdb in Qt, and same result.



  • When you typegdb prog.exe and then type start inside gdb it should say something like:
    ...
    Temporary breakpoint 1 at 0x40.... .... prog.c line 6.
    Starting program...
    ...

    But your gdb.exe is just silent, same as before?



  • @hskoglund Yes it is silent when i type gdb prog.exe ,
    But between the command gdb prog.exe and when it returns : "C:\Programmation\Qt\Tools\mingw810_64\bin>" the computer works about 5 seconds.

    07eedc31-913f-464e-b1e8-72b4846f7d67-image.png



  • Yeah, it's trying to start Python I think.

    One idea you haven't tried (I think): go to Settings and create a new user, logout and login as the new user. Then try gdb.exe when logged in as that new user.



  • @hskoglund OK. I try.



  • @hskoglund I tried with a new account and i have the same thing.



  • About why python does not work good for gdb, could you check the python installation in Qt:

    cd C:\Programmation\Qt\Tools\mingw810_64\opt\bin
    python -c "print 2+2"
    

    If the python command works and prints "4" then could you try the same with the verbose flag:

    python -v -c "print 2+2"
    

    and post the output here...



  • @hskoglund Yes it seams to work :
    4820164e-62d1-4e8d-ac4b-f6d0e16b3631-image.png
    and :
    669cb975-c9a6-406f-89b3-67a4d16c7a77-image.png 5d3d1e3b-f7e8-4230-8bd3-616aaae15ec0-image.png a5a6e75a-9e52-43e8-8713-99ef94b1a609-image.png



  • Ok, looks good. I think to see why your gdb.exe does not run, we need to trace it using Process Monitor, download it here

    Here's what you do:
    start Process Monitor (procmon.exe), type ctrl+L to show the Filter dialog box, in that dialog in the top left corner, in the drop-down list, select "Process Name", then check that the next drop-down list selects "Is" then in the edit box type gdborig.exe and the click the Add button. After that it should look like this:
    Screenshot 2020-07-15 at 11.46.05.png Click OK button to close the dialog box.

    Then start gdb.exe as we did before:

    C:\Programmation\Qt\Tools\mingw810_64\bin\gdb.exe
    

    Now entries should be seen in ProcMon, like this:
    Screenshot 2020-07-15 at 11.47.03.png
    My ProcMon shows 2315 entries for gdborig.exe but your output should be shorter (since it fails) post here say the last 50 lines before it stops.

    Note: you can clear the display of ProcMon using ctrl+X



  • @hskoglund
    I think you have 2315 entries when you look at the bottom of the window. For me i have 362 entries only.
    a301ea80-7037-4360-a64c-afc916a4bb3d-image.png
    I tried an other time and now 356 entries.
    bcb8610e-0d98-40d8-9eac-c6f9c7eecaf7-image.png



  • Ok, could you scroll down in the ProcMon window, so the last lines (before it stops) of the output is shown?



  • @hskoglund Here are the latest lines :
    05d7c75b-d600-4ec3-8edd-2061ae7e0db7-image.png
    And with scroll on the right :
    47c8050d-f897-4d5c-82d3-e97cda8c28a2-image.png



  • Thanks, now I can see the gdborig.exe crash in the Procmon output (the C:\Windows\System32\WerFault.exe line)
    To see the crash info, click on the Start button and type event then select Event Viewer
    In the left column, select Windows Logs and then click on Application, then in the middle window, in the Source column, do you see any gdborig lines? If yes, click on them to see more info in the lower (General) window.

    Edit: gdborig.exe seems to crash when trying to read the C:\msys64\etc\termcap file. If you have MSYS2 installed, try removing or renaming that file.
    Or you could try removing MSYS2 completely (click on Start button, type add or , select Add or Remove programs then search for MSYS2 64-bit in the list, click on it and select Uninstall).



  • @hskoglund
    Here is the report in event :
    9c1d11c6-dd1b-4bef-9bb1-467f28b5a3c1-image.png
    I looked for msys2, but i have not installed this thing. And i can't found it in installed applications.



  • Could you try to start gdb.exe this way:

    C:\Programmation\Qt\Tools\mingw810_64\bin\gdb --nx
    

    (the --nx means: do nor read any .gdbinit files)



  • @hskoglund said in QT 5.15.0 install ::

    C:\Programmation\Qt\Tools\mingw810_64\bin\gdb --nx

    Nothing more :
    3e7017ab-0e74-41b0-803a-410c097444ce-image.png



  • Could you also try:

    C:\Programmation\Qt\Tools\mingw810_64\bin\gdb --configuration
    


  • @hskoglund said in QT 5.15.0 install ::

    C:\Programmation\Qt\Tools\mingw810_64\bin\gdb --configuration

    Nothing :
    df6536f0-e2eb-42fc-a243-8e18f5a128bc-image.png



  • Huh, no good luck today :-(

    Ok we know that gdborig.exe crashes in msvcrt.dll with Access Violation 0xc0000005 but googling that usually only says "try upgrading your Windows 10 or try upgrading your version of MinGW"

    But you already have the latest of both. Maybe you have to wait for Qt 5.15.1...



  • @hskoglund OK.
    I will wait that my computer will be OK to have the latest Windows 10 version. I have the 1909 and the latest is 2004.
    And i will wait for a new version of Qt.
    Or i will reinstall Windows and all my softwares, but it takes a long time.
    And thank you very much for your help.
    Best regards.


Log in to reply