Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QTextToSpeech - No text-to-speech plug-ins were found.



  • Hi

    I am developing a QML based application on windows. I am using Qt_5_14_1_MinGW_32_bit-Release version. I am trying to integrate text to speech in my app. I have followed the hello_speak example. The example works perfectly but my application gives the following error.

    No text-to-speech plug-ins were found.

    I have ensured that the libraries in the .pro file are the same for both the example and my application. Also, I have verified that there is "qtexttospeech_sapi.dll in my build folder.

    Any help in this regard would be highly appreciated.

    Thanks !


  • Lifetime Qt Champion

    Hi,

    From what you wrote you did not deploy the application properly.



  • @SGaist

    I have deployed using windeployqt. I am able to find the testtospeech plugins in the release folder just like the hello_speak example.

    I have used the command:

    windeployqt.exe --quick --release --qmldir ../app_name/ .

    Is there a different way to deploy? I am also quiet sure its a deployment problem.

    It is giving this error when I run in release mode from QT Creator and it works fine in debug mode


  • Lifetime Qt Champion

    Try adding -texttospeech to the windeployqt options.



  • @SGaist
    Adding textttospeech as an option did not work out. I changed my Qt version from 5.14 to 5.15 (latest) and it worked right away

    Thanks ! I am marking it solved for now


Log in to reply