Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qml static application fail to deploy.



  • This question is almost a repetition of what I asked over stackoverflow with a hope that some Qt Guru will throw some light here.

    So, in brief I'm not able to deploy statically linked qml application. Qt is build statically with following command and the problem is not observed on Linux machine.

    Surprisingly the statically build application is running on Windows 10, Ubuntu Wine Environment (VM) but not on Windows 7 (VM).

    Build env
    Windows 10 x64, MinGW 7.3, Qt 5.15.0 (tried with 5.12.8, 5.12.9).

    Config cmd line

    configure.bat -opensource -confirm-license -prefix "C:\Qt\5.15.0-Static" -release -static -static-runtime -opengl desktop -platform win32-g++ -make libs -qt-libpng -qt-libjpeg -qt-freetype -qt-zlib -nomake tools -nomake examples -nomake tests -skip qttools
    

    I'm trying to match my problem with QTBUG-72810 but curious to know why it is running on my build machine Windows 10 with all dev paths removed from PATH and on Windows 10 with no dev kits. Also what could be the story behind Linux wine env.

    Can this be some sort of opengl library issue on Windows 7 VM? I was thinking to try a ANGLE OpenGL build but when I saw that MinGW linker is taking -lopengl32 into account I was not convinced to do that.



  • Found the fix. It was the VM display driver which don't have opengl support. Once I turned on the 3D Acceleration in VirtualBox settings the static application worked perfectly.

    So, I guess the bug has been fixed. I can confirm that I have built Qt 5.15.0 statically on Windows and 5.12.9 on Linux and in both cases static application worked with -opengl desktop.


Log in to reply