Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

WebAssembly for Qt Creator



  • Hi,

    I installed emscripten as mentioned in Qt for Assembly guide for building my Hello World QtQuick app but Qt Creator unable to recognize it (see below)

    alt text

    How can I fix this problem?

    • Linux Mint 19.3 - x64
    • Qt 5.15 (binaries from Qt Installer)
    • Qt Creator 4.12.2
    • Emscripten (terminal output)
    $ em++ --version
    emcc (Emscripten gcc/clang-like replacement) 1.39.8 (commit 6b0d151917fe508007d9d76791369ec94c4eb304)
    Copyright (C) 2014 the Emscripten authors (see AUTHORS.txt)
    This is free and open source software under the MIT license.
    There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
    $ echo $PATH
    /home/tansu/.emsdk:/home/tansu/.emsdk/fastcomp/emscripten:/home/tansu/.emsdk/node/12.9.1_64bit/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/snap/bin
    
    $ emcc -v
    emcc (Emscripten gcc/clang-like replacement + linker emulating GNU ld) 1.39.8
    clang version 6.0.1 (/b/s/w/ir/cache/git/chromium.googlesource.com-external-github.com-emscripten--core-emscripten--fastcomp--clang 98df4be387dde3e3918fa5bbb5fc43e1a0e1daac) (/b/s/w/ir/cache/git/chromium.googlesource.com-external-github.com-emscripten--core-emscripten--fastcomp b4837f88af2d240abb550c0bbd47f3b8ffe5985a) (emscripten 1.38.31 : 1.38.31)
    Target: x86_64-unknown-linux-gnu
    Thread model: posix
    InstalledDir: /home/tansu/.emsdk/fastcomp/fastcomp/bin
    Found candidate GCC installation: /usr/lib/gcc/i686-linux-gnu/8
    Found candidate GCC installation: /usr/lib/gcc/x86_64-linux-gnu/6
    Found candidate GCC installation: /usr/lib/gcc/x86_64-linux-gnu/6.5.0
    Found candidate GCC installation: /usr/lib/gcc/x86_64-linux-gnu/7
    Found candidate GCC installation: /usr/lib/gcc/x86_64-linux-gnu/7.5.0
    Found candidate GCC installation: /usr/lib/gcc/x86_64-linux-gnu/8
    Selected GCC installation: /usr/lib/gcc/x86_64-linux-gnu/7.5.0
    Candidate multilib: .;@m64
    Selected multilib: .;@m64
    shared:INFO: (Emscripten: Running sanity checks)
    
    
    


  • @tansgumus For Qt 5.15, you need emscripten 1.39.8, you have 1.38.8



  • @lorn-potter said in WebAssembly for Qt Creator:

    @tansgumus For Qt 5.15, you need emscripten 1.39.8, you have 1.38.8

    Sorry I sent the wrong log, the right one updated



  • Hi,

    I had the same problem this weekend with Qt 5.15 under Windows 10.

    Try this:

    git clone https://github.com/emscripten-core/emsdk.git --branch 1.39.7 --single-branch
    
    ./emsdk install sdk-1.39.7-64bit
    
    ./emsdk activate sdk-1.39.7-64bit
    

    I started with 1.39.8, but Qt Creator was always complaining that I don't use 1.39.7.

    Additionally since emscripten 1.39.17 the traditional ~/.emscripten config file in the $HOME directory will not be written:

    1.39.17: 06/05/2020
    -------------------
    - On first use, emscripten creates a sample config file.  This config file
      is now created in the emscripten directory by default.  The traditional
      `~/.emscripten` config file in the `$HOME` directory is still supported and
      the sample config will still be written there in the case that the emscripten
      root is read-only.
    

    But as far as I know Qt Creator needs this file.

    Best regards,
    Falko



  • @Falko said in WebAssembly for Qt Creator:

    I started with 1.39.8, but Qt Creator was always complaining that I don't use 1.39.7.

    I updated Qt Creator to the recent version (Qt Creator 4.12.2) but still complains even when I tried to use Emscripten1.39.7!!!