Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Does Qt3D support OpenGL 2.1?



  • Hi,
    The headline says it all, but here is some more information:
    I need to support old systems that are potentially only running on OpenGL 2.1. I cannot find much information about the minimum required OpenGL versions for Qt3D.
    I have seen that Qt 3D Studio (which, as I understand is build on top of Qt3D) requires the OpenGL 3.3 core profile (https://doc.qt.io/archives/qt3dstudio/runtime/qt3d-runtime-requirements.html).

    Am I right to assume that this requrement comes from Qt3D and therefore it won't be a good match for my case?

    I'd be happy to get some input



  • I just received the information from KDAB that Qt3D support starts with OpenGL ES 2 and ranges to modern versions of the API. In the future the RHI will be supported as well.



  • I just received the information from KDAB that Qt3D support starts with OpenGL ES 2 and ranges to modern versions of the API. In the future the RHI will be supported as well.


Log in to reply