Qt World Summit: Submit your Presentation

OpenGL functionality test failed, raspberry pi 3 cross compiling.

  • Hey,

    I have working on building qt for raspberry today, following a tutorial on the raspi forum,

    The tutorial works fine uptil a point except for updating broken links etc.. But when running the last configure /qmake step, there is a issue that I have tried to resolve for a couple of hours now, and I just can't seem to find the correct config files.

    This was the last message i got from qmake

    Note: Also available for Linux: linux-clang linux-icc
    Note: No wayland-egl support detected. Cross-toolkit compatibility disabled.
    ERROR: Feature 'opengles2' was enabled, but the pre-condition 'config.win32 || (!config.watchos && !features.opengl-desktop && libs.opengl_es2)' failed.
    ERROR: The OpenGL functionality tests failed!
    You might need to modify the include and library search paths by editing QMAKE_INCDIR_OPENGL[_ES2],
    QMAKE_LIBDIR_OPENGL[_ES2] and QMAKE_LIBS_OPENGL[_ES2] in the mkspec for your platform.

    Then I went into my qt opensource folder which I build from, and into the mkspecs and changed the lines in the linux common conf file to point to the sysroot directory of the pi (on my ubuntu) where the GLES libraries are located, but there was no change at all.

    I read somewhere that the drivers where renamed lbrcmGLES etc, but I only have the old lGLES etc on the pi after doing searches, so that's probably not the issue for me..

    Anyone succeded in doing this lately?

    The configure command i run is¨

    ../qt-everywhere-opensource-src-5.9.1/configure -opengl es2 -device linux-rasp-pi3-vc4-g++ -device-option CROSS_COMPILE=arm-linux-gnueabihf- -sysroot /opt/qt5pi/sysroot -prefix /usr/local/qt5pi -opensource -confirm-license -skip qtwebengine -skip qtscript -nomake examples -make libs -v

  • Lifetime Qt Champion

    @MEMekaniske Please check config.log file to see what is missing.

  • @jsulm hmm, there was not much to see there at all..

    Command line: -opengl es2 -device linux-rasp-pi3-g++ -device-option CROSS_COMPILE=arm-linux-gnueabihf- -sysroot /sysroot -prefix /usr/local/qt5pi -opensource -confirm-license -skip qtwebengine -skip qtscript -nomake examples -make libs -v

  • I found a conf file under devices for the raspberry but after changing the library include paths it's still not resolved.. could there be any more conf files then the arm-linux and linux-rasp that could need to be modified?

  • I wonder, is Qt support availiable to help with such issues as this for paid small-size customers?

  • Would also be great if both the QTRPI and the Native QT build tuts on wiki io was removed or updated as none of them are up to date.

    https://wiki.qt.io/Native_Build_of_Qt5_on_a_Raspberry_Pi Is missing a lot of packages that is renamed, outdated etc..

    same with https://wiki.qt.io/Qtrpi it only makes jessie images which does not work on any new pies without altering kernel.
    don't remember what error i got trying to build the full version yesterday but think it was some broken links, not strange after 4 years.

  • "Missing EGLFS Fix

    On recent versions of Qt (e.g. 5.10.1), the qmake.conf file for linux-rasp-pi3-g++ doesn't work, however, linux-rasp-pi-g++ does. Create a new qmake.conf based on linux-rasp-pi-g++ with the build flags from the Pi 3 spec copied over.

    Another fix is the replacement of the broken lines:

    VC_LIBRARY_PATH = $$[QT_SYSROOT]/opt/vc/lib
    VC_INCLUDE_PATH = $$[QT_SYSROOT]/opt/vc/include

    Found this on the wiki site, I tried to replace the broken links before I found it, that did not work, but it also says here to build with rasp-pi instead of rasp-pi3 so I'll try that.

    That did not work still the same error...

Log in to reply