Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Forum's Search not working right



  • Ubuntu, Firefox; same on Windows, Chrome. I click the top-level magnifying glass Search icon. I type in, and it displays matching threads. But when I click on one to visit, the dropdown dismisses but nothing happens, I don't move page? I can see that the URL is correct, and I can just about right-click and, say, Open in new tab and it goes there, but just nothing seem to happen on normal left-click to visit?


  • Qt Champions 2017

    @JonB said in Forum's Search not working right:

    Ubuntu, Firefox; same on Windows, Chrome. I click the top-level magnifying glass Search icon. I type in, and it displays matching threads. But when I click on one to visit, the dropdown dismisses but nothing happens, I don't move page? I can see that the URL is correct, and I can just about right-click and, say, Open in new tab and it goes there, but just nothing seem to happen on normal left-click to visit?

    I don't get a dropdown at all (Linux/Chromium). Can you just hit enter and go to the search results page?



  • @kshegunov

    I don't get a dropdown at all (Linux/Chromium)

    I would have thought you do, we must be disagreeing about what I call the dropdown or where you are doing the search? From the magnifying glass, I type my search term, once there are word matches (e.g. ubuntu --- ah, this is the point, it doesn't appear till a whole word is typed, nothing on just ubunt) I get a "big" dropdown with matching posts displayed in a scrolling list, several visible lines per each item.

    Screenshot from 2020-05-03 13-03-30.png

    Can you just hit enter and go to the search results page?

    Didn't think of that, but yes I can. So I cannot use the dropdown --- showing the search matches, which I have looked down to see if I like one of them --- without hitting return, going to the search results page, and looking through all the matches again.

    Even though the item I click on shows the correct URL (on hover), so it's clearly intended to work by clicking. I won't die in a ditch over this, but it seems wrong.


  • Qt Champions 2017

    Yeah now it shows, and it works for me. Odd.


Log in to reply