Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem with deploying OpenSSL with my QT application on Windows.



  • Hi all, i have been working on a qt app and this one uses the network and access HTTPS sites. In my machine everything works fine with no error, but after deployment and shipping the app cant access these https sites and returns an error. So obvious that it is missing the OpenSSL library to be shipped with. I tried to use "QSslSocket::supportsSsl()" to see if each machine supprts ssl or not and yes the client machine doesnt support the library. I tried to move the OpenSSL library in the same directory as the executable but nothing worked. Any idea ? thanks in advance. EDIT: i am using QT 5.13.1 and OpenSSL v1.1.0
    [moderator edit: removed links]


  • Moderators

    Have you run windeployqt to make sure your app is fully deployed with all plugins etc.?

    Which SSL libraries have you copied? Are they in the same folder as .exe file?



  • I've been told that libeay32.dll and ssleay32.dll in Qt\Tools\mingw*\opt\bin is supposed to be used, but I'm not sure how to best include them in a deployment. I was hoping windeployqt handled this, but it seems like it doesn't.

    I see two options. Either copy the dlls manually from the Qt dir into a 3rdparty lib folder that we have full control over, or copy from Qt at each build/deploy.

    The first one has the advantage of giving us control over which version we include. The latter will keep us up to date with whatever Qt version we use include.

    Any thoughts on this? There probably are more options :-)
    [moderator edit: removed links]


  • Banned

    This post is deleted!

Log in to reply