Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can't write into database



  • Hello,
    I'm working on a QML application. I'm trying to insert data to my database table.
    Here is the function i call in my QML.

    void Planning::addToDatabase()
    {
        QSqlDatabase db= QSqlDatabase::addDatabase("QSQLITE","myDB");
        db.setDatabaseName("C:/Users/a.diaw/Documents/sql/databases/dat_modrian.sqlite");
        db.open();
        QSqlQuery querry(db);
        querry.exec("create table planning "
                  "(id integer primary key, "
                  "Username TEXT NOT NULL, "
                  "DebitDose integer, "
                   "Distance integer, "
                   "IrradiationTime integer, "
                   "Start TEXT NOT NULL, "
                   "End TEXT NOT NULL, "
                   "TempsMesure TEXT NOT NULL)");
        for(auto &pal : m_paliers){
    
            querry.prepare("INSERT INTO planning (iD,DebitDose,Distance,IrradiationTime,Start,End,TempsMesyure)"
                           "VALUES (:iD,:Username,:DebitDose,:Distance,:IrradiationTime,:Start,:End,:TempsMesyure)");
            querry.bindValue(":iD",pal->ID());
            querry.bindValue(":DebitDose",pal->debitDose());
            querry.bindValue(":Distance",pal->distance());
            querry.bindValue(":IrradiationTime",pal->iradiationTime());
            querry.bindValue(":Start",pal->irradiationStart());
            querry.bindValue(":End",pal->irradiationEnd());
            querry.bindValue(":TempsMesyure",pal->tempsMesure());
            querry.exec();
        }
        db.close();
    
    }
    

    This function is called when i press a certain button in my window.
    The problem is i get the message error: QSqlDatabasePrivate::addDatabase: duplicate connection name 'myDB', old connection removed.
    And nothing is written in my database. Only the table is created.
    Can anyone help?



  • First things first, as you have - as far as I can tell - two separate problems here.
    First: with each press of the button you add a database connection (so the second time you press it you try to set new connection to db, so the old one is removed, so you get the info). Then each time you create table which might as well exist.
    To avoid that I'd suggest moving the addDatabase and table creation somewhere else, where it is called once. You can retrieve database with:

    auto db=QSqlDatabase::database();
    if (!db.isOpen()) {
    db.Open();
    }
    

    and then continue.
    Also, QSqlQuery returns lastError() and lastError().text() might be useful to debug the execution result.



  • @artwaw thanks you. I moved my database and tableCreation in my main function. I assume that it's called only once then. It still doesn't work. By printing lastError().txt i get the following message:
    SqlQuery::prepare: database not open
    "Driver not loaded Driver not loaded"



  • @Babs Ok. So now you can test db.open() - it returns a value. On false, error should be present in lastError().



  • @artwaw it returns false and the error driver not loaded. I do the verification:

            if(!db.isOpen()){
                db.open();
                qDebug()<<db.lastError().text();
            }
    


  • @Babs Are you completely sure that addDatabase() has been called at any point before call do QSqlDatabase::database()?
    You could also test if driver is available by using QSqlDatabase::drivers() and other methods described in documentation.



  • @artwaw do i have to specify the connectionName when calling database() function?. Add data base in called in my main function before creation my engine.



  • @artwaw the driver for SQLite is indeed present.



  • @Babs can you post your .pro files please?



  • @artwaw i'm working with QBS. When i don't specify the connectionName in addDataBase() function it open. I have the error "number of parameters incorrect". I think i don't have the good parameter types. I defined a QString as a TEXT is SQLite. Is it correct?



  • @artwaw here is my QBS file

    import qbs
    
    
    
    Project{
        name: "PlanningModrian"
    
        Product{
            files: [
            ]
            name: ( "modrian");
            type: "application";
            targetName: (project.targetPrefixTools + "modrian");
            cpp.dynamicLibraries: {
                var ret = [];
                if (Qt.core.versionMinor < 4) { // NOTE : prior to Qt5.4 we had to link libGL manually
                    ret.push ("GL");
                }
                return ret;
            }
    
            cpp.cxxLanguageVersion: "c++14"
            readonly property stringList qmlImportPaths : [sourceDirectory + "/import"]; // equivalent to QML_IMPORT_PATH += $$PWD/import
    
            Depends { name: "Qt.quick" }
            Depends {
                name: "Qt";
                submodules: ["core", "gui", "qml", "quick","testlib","sql"];
            }
            Group{
                name: "C++ sources";
                files: [
                    "planning.cpp",
                    "main.cpp",
                    "admin.cpp",
                    "testPlanning.cpp",
                    "user.cpp",
                    "equipement.cpp",
                    "equimenttablemodel.cpp",
                    "palier.cpp",
                    "paliermodel.cpp",
                    "appwrapper.cpp",
                ]
            }
            Group {
                qbs.install: (product.type === "dynamiclibrary");
                fileTagsFilter: product.type;
            }
    
            Group{
                name: "C++ headers";
                files: [
                    "admin.h",
                    "appwrapper.h",
                    "datetimevalidator.cpp",
                    "datetimevalidator.h",
                    "equimenttablemodel.h",
                    "manager.cpp",
                    "manager.h",
                    "paliermodel.h",
                    "planning.h",
                    "user.h",
                    "equipement.h",
                    "palier.h",
                ]
            }
            Group  {
                name: "QML files"
                files: [
                    "DatePicker.qml",
                    "DateUtils.js",
                    "Planning.qml",
                    "main.qml",
                    "PagePlannification.qml",
                    "qml.qrc",
                ]
            }
    
            //Depends { name: (project.namePrefixBase + "utils"); }
            Depends { name: "libqtqmltricks-qtsupermacros"; }
            Depends { name: "libqtqmltricks-qtqmlmodels"; }
            Depends { name: "libqtqmltricks-qtquickuielements"; }
        }
    }
    
    


  • @Babs ups. I have literally zero experience with qbs...
    I am afraid you'll have to wait for someone who knows something about it, I am sorry.



  • I resolved my problem. I made an error in the type an name of one of the parameters. Thanks for your help @artwaw.



  • @Babs Anytime.
    Please don't forget to mark the thread as "solved".