"Module "QtQuick" version 1.1 is not installed" when running application on device



  • I've updated Qt SDK to the latest one (4.7.4 with Symbian Belle support). Now I have a problem when trying to run my QML application on the hardware from Qt Creator. The problem is that if I use normal silent installer, it gives this message:

    module "QtQuick" version 1.1 is not installed

    If I use Smart Installer Package option, I get pretty much the same result. It's just not printed to the Qt Creator output window.

    So how do I install this QtQuick 1.1 on Nokia N8? Or, is there a way to go back to QtQuick 1.0?



  • Hi!

    I have got same problem - but I was created Anna application instead of Belle...

    There is a file "QtQuickComponents-1.1-for-Anna-Belle.sis" in location "c:\QtSDK\Symbian\sis\Symbian_Anna\QtQuickComponents\1.1".

    Is it that what I have to install on my N8? Can I unistall it if necessary?

    Thank you!



  • I'd like to know the answer as well. I don't have that sis file jczettler mentions, and I tried using the Qt Updater to install the Symbian Anna Toolchain, but it didn't work. The error still shows up. I don't think it's a matter of qt 1.1 not being on the phone, the latest Nokia Store is programmed using it and the symbian components, no?



  • I take it back, I was able to fine the sis, and it did solve the problem. Not sure about being able to uninstall it though..



  • My hardware comes from China vendor and their people have done the embedded Linux installation and Qt port. What can/should I look for as far as files to know if QtQuick/QML is supported? console output from a QML sample application built for the target indicates the following:

    qrc:ellipse5.qml:1:1: module "QtQuick" is not installed

    Thanks in advance,

    John


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.