[SOLVED] Updating to QtQuick 1.1 and Qt 4.7.4



  • I've updated the tools with automatic updater. Now it seems that QtQuick has updated to version 1.1, as well as com.nokia.symbian components too - 1.1. The problem with that is when I try to run application on my Nokia N8 device. I get this message:

    @[Qt Message] file:///C:/Private/e496b448/qml/thursday2/main.qml:1:1: module "QtQuick" version 1.1 is not installed
    import QtQuick 1.1 @

    My understanding is that QtQuick 1.1 is meant for Symbian Belle, while N8 is currently using Symbian Anna. Is it so? Also, I still need to develop for Symbian Anna. How do I get Qt Creator to use QtQuick 1.0 and com.nokia.symbian 1.0 libraries now?

    Huge mess :D



  • One another issue I got now after updating the SDK: my project from Qt 4.7.3 is not compiling for Symbian target anymore. I get this:

    @Error while building project Ringi (target: Symbian Device)
    When executing build step 'qmake'@

    What might be going wrong here?



  • If you package your app with the Smart Installer it should automatically pull down Qt Quick 1.1



  • Enabling Smart Installer option doesn't work (though it installs something during the process). I still get a black screen after application started, which is exactly what I'm getting also without that Smart Installer option.



  • Ok, after playing with project properties and switching to use Symbian Belle Debug (though I have only Symbian Anna on the device) I managed to create a smart installer that (I think) installed me QtQuick 1.1 to the device.

    Now I'm getting this:

    [Qt Message] file:///C:/Private/e44063f0/qml/friday/main.qml:2:1: module "com.nokia.symbian" version 1.1 is not installed
    import com.nokia.symbian 1.1

    Haven't figured out how to get through this one yet.



  • This is solved now. The problem was with SDK 1.1.4 installer not including Symbian components for MinGW and Symbian Anna by default.



  • I am having the same problem: trying to install Qt Quick Components v1.1 on Symbian Anna device (E7). What do you mean by:
    bq. The problem was with SDK 1.1.4 installer not including Symbian components for MinGW and Symbian Anna by default.

    means that when you installed Qt SDK you didn't have visual studio installed on your PC, and un-installing Qt SDK, installing Visual Studio and then installing again the Qt SDK fixed this?

    If I go to Windows->Programs->Qt SDK->Symbian Anna Qt 4.74->Install Qt Quick Components 1.1 for Symbian Anna device. When I do this, total surprise: Windows pops-up the following dialog:

    “The item ‘qtcomponents_1_1.sis’ that this shortcut refers to has been changed or moved, so this shortcut will no longer work properly. Do you want to delete this shortcut?”

    So how did you fix your problem exactly?

    Thanks,
    Ionut



  • Hey, deion

    I'm not using Visual Studio at all. That was the problem - the SDK is not installing Symbian components for MinGW and Symbian Anna.

    In order to install Qt Quick components onto device (E7), you have to create a smart installer package with Qt Creator, and install it. This will install all the missing Qt libraries on the device.

    Smart installer is the option in the Projects -> Run -> Create SIS Package -> Create Smart Installer package



  • Hi,

    Thanks for the reply.

    I found another solution in the end: Qt Quick Components 1.1 sis file can be found in:
    QtSDK\Symbian\sis\Symbian_Anna\QtQuickComponents\1.1\QtQuickComponents-1.1-for-Anna-Belle.sis

    Regards,
    Ionut


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.