Important: Please read the Qt Code of Conduct -

(need help) to make my first app with WebAssembly

  • Greeting,

    I use those step to make my first app with WebAssembly, but still I'm not able to run my app

    emsdk install sdk-fastcomp-1.38.30-64bit
    emsdk activate --embedded --global sdk-fastcomp-1.38.30-64bit

    Adding directories to PATH:
    PATH += C:\emsdk
    PATH += C:\emsdk\fastcomp-clang\e1.38.30_64bit
    PATH += C:\emsdk\node\8.9.1_64bit\bin
    PATH += C:\emsdk\python\\python-2.7.13.amd64
    PATH += C:\emsdk\java\8.152_64bit\bin
    PATH += C:\emsdk\emscripten\1.38.30

    Setting environment variables:
    EMSDK = C:/emsdk
    EM_CONFIG = C:\emsdk.emscripten
    EM_CACHE = C:/emsdk/.emscripten_cache
    LLVM_ROOT = C:\emsdk\fastcomp-clang\e1.38.30_64bit
    EMSCRIPTEN_NATIVE_OPTIMIZER = C:\emsdk\fastcomp-clang\e1.38.30_64bit\optimizer.exe
    BINARYEN_ROOT = C:\emsdk\fastcomp-clang\e1.38.30_64bit\binaryen
    EMSDK_NODE = C:\emsdk\node\8.9.1_64bit\bin\node.exe
    EMSDK_PYTHON = C:\emsdk\python\\python-2.7.13.amd64\python.exe
    JAVA_HOME = C:\emsdk\java\8.152_64bit
    EMSCRIPTEN = C:\emsdk\emscripten\1.38.30




    mingw32-make: Symbolic links not supported: disabling -L.
    mingw32-make: *** No rule to make target 'C:/Qt_Setup/5.14.0/wasm_32/lib/libqtmain.a', needed by 'GoWeb.exe'. Stop.
    02:28:48: The process "C:\Qt_Setup\Tools\mingw730_64\bin\mingw32-make.exe" exited with code 2.
    Error while building/deploying project GoWeb (kit: Qt 5.14.0 WebAssembly)
    The kit Qt 5.14.0 WebAssembly has configuration issues which might be the root cause for this problem.
    When executing step "Make"

  • Did you enable the experimental webassembly plugin in QtCreator?

  • Hello, I am having the same issue.

    Did you manage to solve it ?
    Thank you

Log in to reply