Qt Everywhere Opensource on Ubuntu 10.04



  • Hi,

    After losing faith in Fedora I moved over to Ubuntu but have hit another stumbling block whilst trying to get QT4.7.4 running -

    I'm trying to build with phonon included as so

    bq. ./configure -v -embedded arm -xplatform qws/linux-arm-imx -phonon -force-pkg-config

    This gives;

    bq. ...
    Cups auto-detection... ()
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-g++ -c -pipe -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-imx -I. -o cups.o cups.cpp
    cups.cpp:42:23: error: cups/cups.h: No such file or directory
    cups.cpp: In function 'int main(int, char**)':
    cups.cpp:46: error: 'cups_dest_t' was not declared in this scope
    cups.cpp:46: error: 'd' was not declared in this scope
    cups.cpp:47: error: 'cupsGetDests' was not declared in this scope
    make: *** [cups.o] Error 1
    Cups disabled.
    D-Bus auto-detection... ()
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-g++ -c -pipe -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-imx -I. -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -o dbus.o dbus.cpp
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-g++ -Wl,-O1 -o dbus dbus.o -L/lib -ldbus-1 -lpthread -lrt
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/lib/gcc/arm-none-linux-gnueabi/4.1.2/../../../../arm-none-linux-gnueabi/bin/ld: skipping incompatible /lib/libdbus-1.so when searching for -ldbus-1
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/lib/gcc/arm-none-linux-gnueabi/4.1.2/../../../../arm-none-linux-gnueabi/bin/ld: cannot find -ldbus-1
    collect2: ld returned 1 exit status
    make: *** [dbus] Error 1
    D-Bus disabled.
    Glib auto-detection... ()
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-g++ -c -pipe -O2 -Wall -W -I../../../mkspecs/qws/linux-arm-imx -I. -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -o glib.o glib.cpp
    glib.cpp: In function 'int main(int, char**)':
    glib.cpp:55: warning: 'pollfd' is used uninitialized in this function
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/bin/arm-none-linux-gnueabi-g++ -Wl,-O1 -o glib glib.o -pthread -lgthread-2.0 -lrt -lglib-2.0
    /opt/freescale/usr/local/gcc-4.1.2-glibc-2.5-nptl-3/arm-none-linux-gnueabi/lib/gcc/arm-none-linux-gnueabi/4.1.2/../../../../arm-none-linux-gnueabi/bin/ld: cannot find -lgthread-2.0
    collect2: ld returned 1 exit status
    make: *** [glib] Error 1
    Glib disabled.
    Phonon support cannot be enabled due to functionality tests!
    Turn on verbose messaging (-v) to ./configure to see the final report.
    If you believe this message is in error you may use the continue
    switch (-continue) to ./configure to continue.

    If I do not include Phonon then the build succeeds. I think I have all the packages I require, looking through my package manager everything appears to be there.

    As you can tell I'm new to Linux and QT, any help would be greatly appreciated.



  • Since you're cross compiling, are you sure you have everything (that phonon needs) provided by your toolchain? I can see that glib is missing, and IIRC that's required by the gstreamer backend.



  • Hi peppe,

    I ran

    bq. apt-get install glib*

    And everything installed on the glib side. I still get the same error when trying to configure Qt.

    edit: I have looked through the requirements here http://doc.qt.nokia.com/stable/requirements-x11.html#phonon-dependencies and attempted to install all the required packages. A few would not install due to unmet dependencies but I'm not sure how to remove those conflicts?



  • You must install those libraries for the embedded toolchain, not the host one. See if your toolchain ships with those libraries, otherwise recompile them.



  • Hi again,

    Sprry I was not more clear - I was able to configure Qt4.7.4 OS exactly as I have attempted to do here on my previous Fedora based host. I then moved over to an Ubuntu based host and followed the same steps (trying to install any missing packages on the host) but I still have no luck. My target and target toolchain have not changed.

    [quote author="peppe" date="1320679675"]You must install those libraries for the embedded toolchain, not the host one. See if your toolchain ships with those libraries, otherwise recompile them.[/quote]


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.